Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to sign into any Apple Website

  • 6 replies
  • 1 has this problem
  • 16 views
  • Last reply by FriedSquee

more options

Hi,

I am unable to login to any Apple websites (Apple Music, Apple Support and the Apple Beta program page), it just spins trying to load the login form.

Tested on Chrome and it brought the login page up instantly, then tried a Firefox Nightly install and this too was able to bring the login page up.

Then decided must be an add-on so restarted in Safe mode, deleted all Cookies & Cache and disabled hardware acceleration but still no luck with getting through; has anyone experienced this before and can point me in the right direction?

Thanks in advance!

Attached screenshots

All Replies (7)

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content. .


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

more options

cor-el said

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. Firefox shows a purple shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content. .

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Thanks for the above, I tried all of the options to no luck; still unable to get the login details to appear.

Helpful?

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !


Remove History For One Site {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H.
In the search bar, enter the name of the site. Right-click on one of the listings and select
Forget About This Site.
This should remove all information, including any site settings

Helpful?

more options

You can check the Web Console for messages about blocked content.

Helpful?

more options

FredMcD said

Please provide a public link (no password) that we can check out. No Personal Information Please ! Remove History For One Site {web link} Open the History Manager <Control> (Mac=<Command>) <Shift> H.
In the search bar, enter the name of the site. Right-click on one of the listings and select
Forget About This Site.
This should remove all information, including any site settings

I have already removed the history for the site and no luck.

Website is: https://music.apple.com/gb/browse and the click the 'Log In' button at the top right. For me this just brings a white box that just spins and doesn't go anywhere no matter how long I leave it,

Helpful?

more options

cor-el said

You can check the Web Console for messages about blocked content.

Web Console after clicking on the 'Log In' button:

- Metrics config: no config provided via delegate or fetched via init() - Cookie "media-user-token" will be soon rejkected because it has the "sameSite" attribute set to "none" or an invalid value - Content Security Policy: Ignoring 'x-frame-options' because of 'frame-ancestors' directive.

Not sure if these mean anything to you? Also noticed that certain websites keep thinking I am a bot and making me do Captcha checks

Helpful?

more options

FredMcD said

Please provide a public link (no password) that we can check out. No Personal Information Please ! Remove History For One Site {web link} Open the History Manager <Control> (Mac=<Command>) <Shift> H.
In the search bar, enter the name of the site. Right-click on one of the listings and select
Forget About This Site.
This should remove all information, including any site settings

No Luck on this front, I had tried that previously but it still doesn't load.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.