Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Incorrect display of the digit 9

  • 3 replies
  • 1 has this problem
  • 28 views
  • Last reply by fcl

more options

Firefox occasionally displays the digit 9 as a dash "-". On any particular website this can occur on all pages, only some pages or on one part of a page and not another part of the same page. This occurs in the same places on Chrome and Opera but it does not occur on Safari. I have seen it occur on text sent from a website as well as on text I type. In one example, the font-family is Helvetica and the problem occurs on larger font-sizes but not smaller sizes sent from the website. In another example, when typing a credit card number, the font-size is typically small and the problem does occur. I am using Firefox version 77.0.1 on Mac OS 10.11.

Chosen solution

We seen this reported before and this is usually caused by a corrupted default font that isn't a TTF and changing to a true type font might fix this.

Read this answer in context 👍 0

All Replies (3)

more options

Hi jcl....

could you review your default fonts and change them to TrueType fonts for testing? Here's how:

Open the Preferences page:

   Mac: "3-bar" menu button (or Firefox menu) > Preferences
   Windows: "3-bar" menu button (or Tools menu) > Options
   Linux: "3-bar" menu button (or Edit menu) > Preferences
   Any system: type or paste about:preferences into the address bar and press Enter/Return to load it 

Scroll down to the Language and Appearance section, and click the Advanced... button. This should open th

e Fonts dialog.

(1) Select the Latin character set

Near the top there is a character set selector. Latin is used for pages in English.

(2) Change the fonts to basic TrueType fonts

Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages.

Firefox may work most reliably with the built-in system fonts.

   Serif - Change from Times or Times Roman (or other serif font) to Times New Roman 
   Sans-serif - Change from Helvetica (or other sans-serif font) to Arial 
   Monospace - Change from Courier (or other fixed-pitch font) to Courier New 

(3) Repeat #1 and #2 with the "Other Writing Systems" character set

(4) Click OK to save changes

Any difference on the problem sites?

Screenshot for reference:

tell me its help...

thank you!

Helpful?

more options

Chosen Solution

We seen this reported before and this is usually caused by a corrupted default font that isn't a TTF and changing to a true type font might fix this.

Modified by cor-el

Helpful?

more options

Arman Khan's solution was helpful in pointing to the font preferences of Firefox. However, following his suggestion did not solve the problem unless I also unchecked the box "Allow pages to choose their own fonts, instead of your selections above." That is not ideal as it substitutes a default font for the font chosen by the web designer. Cor-el was on target by suggesting a corrupt system font. By going to the Font Book app and resolving duplicate fonts that are in my folder, the problem with Firefox, as well as with Opera and Chrome, was resolved.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.