Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Suddenly TB cannot open jpg file incoming email attachments, other types open OK.

  • 10 replies
  • 1 has this problem
  • 864 views
  • Last reply by BaliDave

more options

I had specified that jpg files be opened by PIcasa Photo Viewer and all had been working well for years -- this new behavior started a few months ago. All other file types open as expected, e.g. csv is opened by Excel, pdf by Reader, ...No matter what setting I use for associating with jpg files, clicking on the attachment just stores them in my appData/Local/TEMP directory, and Picasa doesn't open the file tho it updates the contents of that folder.

I first tried all the different options for jpg file types, including save file, Use Default, Always Ask, choosing another program to open jpg's, ... and all did the same thing. I then deleted the associated JPG option for incoming attachments and tried again to open it, but it still just copies the jpg to the TEMP dir, and I don't get prompted for anything. Same behavior for all when using SAFE mode too.

[Note in the attached image I show the choices for JPEG, not JPG, because I just deleted the JPG action and it won't come back. Anyhow I've tried every combination, including the bottom part about where to save files to as well as the drop down list]

I'm on Win 10 x64 using TB 68.10.0 (32 bit)

Any ideas?

I had specified that jpg files be opened by PIcasa Photo Viewer and all had been working well for years -- this new behavior started a few months ago. All other file types open as expected, e.g. csv is opened by Excel, pdf by Reader, ...No matter what setting I use for associating with jpg files, clicking on the attachment just stores them in my appData/Local/TEMP directory, and Picasa doesn't open the file tho it updates the contents of that folder. I first tried all the different options for jpg file types, including save file, Use Default, Always Ask, choosing another program to open jpg's, ... and all did the same thing. I then deleted the associated JPG option for incoming attachments and tried again to open it, but it still just copies the jpg to the TEMP dir, and I don't get prompted for anything. Same behavior for all when using SAFE mode too. [Note in the attached image I show the choices for JPEG, not JPG, because I just deleted the JPG action and it won't come back. Anyhow I've tried every combination, including the bottom part about where to save files to as well as the drop down list] I'm on Win 10 x64 using TB 68.10.0 (32 bit) Any ideas?
Attached screenshots

Chosen solution

how about yo delete the action for JPEG files from Thunderbird entirely and then restart it. That will clear any corruption that might exist in the mime handler settings. Next time you try and open a JPEG you will be asked as the setting will default back to ask.

Read this answer in context 👍 1

All Replies (10)

more options

I'm on Windows 10 x64 TB 68.9.0 and have to use : 'Use TWINUI (default)'

I also use 'always ask me where to save files'

Just updated to 68.10.0 and still opens ok using the above.

more options

In Windows 10, I set the default app for Photo viewer to 'Photos' and in Thunderbird it will open using that app. If I change the Windows 10 default app to eg: Paint then I can get Thunderbird to open using that app. But in Thunderbird I still have the 'Use TWINUI (default)'.

So try setting TWINUI in Thunderbird and Windows 10 default Photos app to PIcasa Photo Viewer.

Modified by Toad-Hall

more options

Toad-Hall: Thanks, but right now I do not have, nor seem to be able to get any option for JPG files. And I never had the 'Use TWINUI (default)' one. I did try all possible choices and finally deleted the JPG option there in hopes of getting it back when I tried again to open a jpg file attachment. But alas, it just immediately stores the jpg in the TEMP directory and that's it.

Note that I can do a Save As with the jpg with the right-click option, but single clicking the jpg just stores it in my TEMP directory. This works the same in Safe mode too.

I'm wondering what's different with my setup and why others don't seem to experience this. THanks anyhow.

more options

In Options > Attachments : Have you changed the setting to use 'always ask me where to save files' ?

more options

I'm running Windows 10 1909 and it is up to date. But it sounds like you do have TWINUI on system.

In Windows 10 default apps for Photos, have you selected PIcasa Photo Viewer?

more options

Toad-Hall said

In Options > Attachments : Have you changed the setting to use 'always ask me where to save files' ?

Yes, but same thing. [BTW, sorry for late response, I didn't learn of it until just now.]

more options

Toad-Hall said

I'm running Windows 10 1909 and it is up to date. But it sounds like you do have TWINUI on system. In Windows 10 default apps for Photos, have you selected PIcasa Photo Viewer?

Yes, I have Picasa Photo Viewer as default app for Photos and that works fine any other time I open a jpg from another app or FileExplorer. It's only TB's jpg attachments that cause this. And strange now I can't get TB to prompt me at all for jpg files -- just stores them in my TEMP area.

Interestingly png and gif files work fine -- I do have the TB default action for them set to PIcasa Photo Viewer and also for jpeg files. But jpeg files do the same as jpg -- they just go to the TEMP area and do not display. Attached are all my defaults (note that I can't get prompted to regain a default for jpg files) and the setting for where to save files. Any ideas?

more options

Chosen Solution

how about yo delete the action for JPEG files from Thunderbird entirely and then restart it. That will clear any corruption that might exist in the mime handler settings. Next time you try and open a JPEG you will be asked as the setting will default back to ask.

more options

Matt's comment is worth trying.

I just had a pdf that had no idea what to use to open and did not even offer Adobe Reader as an option in additional apps! go figure !

Had to locate the exec file to get it up and running again. Yep it was in the attachment settings and been perfectly ok for ages, but hey ho.

I have found that Windows 10 does mess about with .jpg in registry. For example, if I want to add an image to this comment, you click on 'browse' to locate the image and in the new window it will say 'All supported types' followed by list of extensions. However, every now and again (after Win10 update) the 'All supported types' will not include .jpg, forcing me to select 'all files' just to see the .jpg images in the selected folder. I then need to fix the registry setting to sort it out.

Could you test trying to add an image in this forum - click on 'Browse' and window opens. Bottom right it should say 'All supported types' followed by list of extensions. Is .jpg included in the list ?

more options

That's fixed it!! I deleted both the JPEG and JFIF options in TB, shut down, and now all work fine. THANKS Matt!!

Todd-Hall, Thanks for your persistence in this -- we were getting close. I do have a jpg in this forum (my last post before this one), but I couldn't get a Browse option (not sure how to do that), so unable to try your experiment. Clicking on it opens the image, and right-clicking doesn't give me any such option.

Anyhow many thanks to both of you! Dave