Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This page keeps refreshing itself

more options

This page keeps refreshing itself. Clicking the Refresh X stops it:

https://www.healthline.com/nutrition/decaf-coffee-good-or-bad

. . . since I just updated to 78.0.1 (64-bit) . . . ? It looks like a bug to me.

Chosen solution

after 30 seconds or so of continuous Refresh, I saw:

statusCode 503

error "Service Unavailable"

message "Borken"


Now I go to the page, and it's working with my Default profile. Looks like they fixed something.

Read this answer in context 👍 0

All Replies (9)

more options

hello sludge7051-x,

follow the steps and instructions:

The process for blocking auto-refresh is much simpler in firefox:

  • Just type about:config into the Firefox address bar,
  • Accept the risks and continue show on screen press enter
  • Then copy accessibility.blockautorefresh and paste it on bar which show on browser

Right-click this preference and click “Toggle” to change its value from “false” to “true,” thereby disabling auto-refresh in Firefox.


tell me its help.

Thank you and Regards,

Arman

Helpful?

more options

Hi sludge7051-x, it is difficult to know when odd site behaviors could be due to customizations we've added to our installations of Firefox over the years. Here's something you could try to try to bypass those without disrupting your regular browsing:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like July2020, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (July2020 will remain available for future testing.)

IMPORTANT: Creating a new profile may change your default. If your regular profile has a Set as Default Profile button after this test, click that to make sure your next startup doesn't yield a surprise.


One site where users report website problems is: https://webcompat.com/

Helpful?

more options

I found this in my Settings notes:

- - - - - - - - - - - - - - - - - - - - - -

How to disable auto refresh of web pages (Meta Refresh)

This used to be under Advanced, but is now in about:config

- - - - - - - - - - - - - - - - - - - - - -

Tools / Options / Advanced / General [un-check] Warn me when websites try to redirect or reload the page

- - - - - - - - - - - - - - - - - - - - - -

Disable automatic Meta refresh/redirect of websites in browser for security reasons 02/01/10 http://www.jkwebtalks.com/2010/02/disable-automatic-meta-refreshredirect.html

Firefox 56+: Where is ‘Warn me when websites try to redirect or reload the page’ Option? 01/24/18 http://techdows.com/2017/10/firefox-56-warn-me-when-websites-try-to-redirect-or-reload-the-page-option.html

- - - - - - - - - - - - - - - - - - - - - -

04/07/15 un-check it - it seems like it slows me down more than it protects 05/07/15 check it - helps to keep many pages from opening up on tripod.com 06/11/15 un-check it - couldn't get to Sears Store Card statement 01/12/16 check it - I don't like seeing Yahoo's headlines after I exit e-mail 11/16/17 the setting is gone, now, it can only be set it in about:config 01/24/18 this setting is now only available in about:config 10/04/19 disable this / set to false - I could not get to checkout on the Lowes site 10/07/19 it's set to not "Auto Refresh", for security purposes, but I think I'll be ok with it "on" 07/20/20 continuous Refresh page: I had this set to false - I set it to true, did not fix

about:config accessibility.blockautorefresh double click it / change 'Value' to false restart Firefox

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

about:profiles / Create a New Profile / Next / Assign a name like 20_07_02 . . . [sometimes dashes can cause a problem] . . . ignore the option to relocate the profile folder / Finish

[this is a good idea] Restart with Add-ons Disabled / about:profiles

Profile: 20_07_02 This is the profile in use and it cannot be deleted.

Firefox should open a new window that looks like a brand new, uncustomized installation . . . Yes

ignore any tabs enticing you to connect to a Sync account or . . . Ok

Do the problem site(s) work any better in the new profile? . . . It works as expected now, in the new Profile, no continuous Refresh

about:profiles / Reset default as the "Default" profile . . . It's back to continuous Refresh: . . . https://www.healthline.com/nutrition/decaf-coffee-good-or-bad . . . With Add-ons disabled, it just flickers on and off in the bar at top . . . after 30 seconds or so of that, now I see:

statusCode 503 error "Service Unavailable" message "Borken"

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Apparently, it's something else in my default Profile

Helpful?

more options

not sure if my posts are going through

Helpful?

more options

It looks like there's a limit on how much text you can post - and, line breaks are not retained.

Summary:

1.) I had accessibility.blockautorefresh on false . . . set to True didn't fix it . . . with all Add-ons enabled or disabled

2.) Using the new profile fixes it

Apparently, it's something else with my default Profile

Helpful?

more options

Sorry about that, there is a link filter that affects newer posters, so your replies need to wait for a moderator's approval. There is supposed to be a little notification after the post is submitted but it may be too subtle.

Helpful?

more options

sludge7051-x said

1.) I had accessibility.blockautorefresh on false . . . set to True didn't fix it . . . with all Add-ons enabled or disabled

2.) Using the new profile fixes it

Apparently, it's something else with my default Profile

Hmm, so it's not the add-ons, it must be something else. If the site doesn't explain why it needs to reload, it can be difficult to guess. Does it work any better in a private window (this bypasses any cached files or saved cookies for the site)?

Helpful?

more options

Chosen Solution

after 30 seconds or so of continuous Refresh, I saw:

statusCode 503

error "Service Unavailable"

message "Borken"


Now I go to the page, and it's working with my Default profile. Looks like they fixed something.

Helpful?

more options

. . . moderator's approval notification after the post is submitted but it may be too subtle

Yes - I didn't see anything

Thanks for your help!

Modified by sludge7051-x

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.