Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Pages will not open since update to FF

  • 7 replies
  • 1 has this problem
  • 69 views
  • Last reply by FredMcD

more options

Nothing but problems with FF after yesterday's update. It will not open my home page or bookmarked pages like twitter. See the attached image from clicking on the home icon. I tried uninstalling & reinstalling and still it won't work. I get a message asking me to sign in and to use a code sent to my hotmail, but no email is ever sent, when I go to my email accts using Chrome. I'm not interested in Firefox sync which is what it wants me to sign in to. I've searched your solutions and changed my firewall settings (removing and then adding back Firefox). Still doesn't work. I had my Firefox account set up to use my two email accts as my home pages, but now neither will open unless I use Chrome. I can open links from my favorites list using FF, so it will work for some links. Please help me get it back to normal.

Attached screenshots

Chosen solution

That was very good work. Well Done.
Please flag your last post as Solved Problem as this can help others with similar problems.


Sometimes weblinks get changed or retired.

Read this answer in context 👍 0

All Replies (7)

more options

Type about:preferences#advanced<Enter> in the address bar.
Under Advanced, Select Network.

[v56+] Type about:preferences#general<enter> in the address bar.
Look for Network.
+++++++++++++++++++++++++++++++++++++++++
Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first try No Proxy. If there is a problem, then try System Proxy.


Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem:
To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet {web link}

more options

Thanks for trying to help, but I still cannot get FF to work correctly. First I clicked on the Windows logo, there was no "Control Panel" choice shown. I typed it into the search box at the bottom and did get it to open. Went into "System and Security" clicked on "Allow an app through Windows Fire Wall". Clicked on "Change Settings" and scrolled down the list to "FireFox". It did not say "FireFox exe", but if I clicked on Details, it showed: C:\Program Files\Mozilla Firefox\firefox.exe I then removed it from the list and followed the instructions to add it back. It has both Private and Public browsing clicked. There was no "Mozilla" on the list. I then opened a new tab in Firefox and tried to go to my home page and to a bookmarked site and neither would open. Just a blank page shows up, no warning or message. I can open the "Favorites" list of bookmarks and they will go to the correct page and open it up. I have checked my security settings and it shows Windows fire wall as the only one I have. Am I the only one having this problem since the last Firefox update? I still need a solution.

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox.
Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode
Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

I tried opening both FF and my computer in safe mode, testing both one at a time and still my hotmail account and twitter will not open. Only a blank page shows with any message or warning. I tried going to each using a search engine link and still no luck. I can go to other sites from bookmarks including my gmail acct. If I use my other browser, Chrome, all sites will open without any problems. This only started happening after the last FF update. Can I roll back that update? As I explained earlier, I did a removal of FF and reinstalled it but that latest version included the latest update as well. I tried to see if I could roll by computer back to an earlier date but there were no earlier reset dates available.

more options

Hello Susan,

FredMcD   asked me to tell you that due to certain circumstances, he can't post anything on the support forum right now.

more options

Thank you and Fred for trying to help. I was able to figure out a solution this morning. I did a search for "opening a hotmail acct" and was able to open that page that included a link for already existing accts. I was able to go to my inboxes for both my hotmail and gmail accts. doing this and create new links for them to be my opening pages when I open Firefox. Why the old links quit working and why some of the search links going directly to a log in page, would not work I don't know. I was also able to go to my twitter account the same way and created a new bookmark link for it. Again it all started right after the latest FF update, so it has to do with that somhow.

more options

Chosen Solution

That was very good work. Well Done.
Please flag your last post as Solved Problem as this can help others with similar problems.


Sometimes weblinks get changed or retired.