Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"" can't be opened.

  • 3 replies
  • 1 has this problem
  • Last reply by ldhess

more options

I am running MACOS 10.15.5 on a MacBook Pro. Up until recently Firefox has worked perfectly. Now, and for maybe the past week or so, I get the pop-up error message "" can't be opened. No other indications or messages.

I have removed and reinstalled the app from the Firefox 77.0.1.dmg file. Still have the issue. I get the same msg when attempting to start Firefox in safe mode. I thought at first this issue may be due to the upgrade to 10.15.5 from 10.15.4, but a family member's Firefox works perfectly on 10.15.5. I actually don't remember when the jump to "5" from "4" actually happened. I have checked the forms and found nothing relating to this specific error. Perhaps I missed it.

I have attempted to recover Firefox from an earlier (6/2/2020)Time Machine backup which I believe was prior to the "5" upgrade, but the message is still the same.

Any help/suggestions would be appreciated. Thanks.

Attached screenshots

All Replies (3)

more options


If there are problems with updating or with the permissions then best is to download the full version and trash the currently installed version to do a clean install of the new version.

Download a new copy of the Firefox application and save the disk image file to the desktop

Your personal data is stored elsewhere in the Firefox profile folder, so you won't lose personal data like bookmarks when you uninstall and (re)install or update Firefox.


more options

Thanks, however, as I attempted to lay out in my initial question, 1) I get no other information besides the cryptic mention of permissions, etc. 2) I have uninstalled the app (both by merely trashing it from the applications folder and also by using CleanMyMac) and reinstalled it using a fresh download. The downloaded file is Firefox 77.0.1.dmg. 3) The problem persists.

Additional information as I have just attempted the trash and reinstall. On first execution attempt I do get the " an app downloaded from the internet..." upon which I click open. Nothing happens. When I attempt to open from the Applications Folder, the message appears.


more options

Looking for help again. I fixed the issue by, and for completely different reasons, reinstalling Catalina and restoring everything, downloading Firefox 76.0.1 and installing that back level version. Worked great. Firefox migrated to 77.0.1 at some point and was working perfectly, until just now. The same error is occurring. I've no idea what might have happened. Would appreciate any ideas. Thanks.


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.