Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I seem to have disabled the Clear Recent History feature

  • 2 replies
  • 1 has this problem
  • 24 views
  • Last reply by jdbinfo750

more options

The Clear Recent History option is grayed out after visiting System Preferences.

Chosen solution

hello jdbinfo,

follow the steps resolved your problem:

1. click 3 horizontal line.

2. click options.

3. privacy and security.

4. History < firefox will:

  • Use custom settings for history.

5. Deselect: [ ] "Always use Private Browsing mode

6. Restart firefox browser.

I hope resolved your problem reply back to me.

Thank you asked Questions in Mozilla support.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

hello jdbinfo,

follow the steps resolved your problem:

1. click 3 horizontal line.

2. click options.

3. privacy and security.

4. History < firefox will:

  • Use custom settings for history.

5. Deselect: [ ] "Always use Private Browsing mode

6. Restart firefox browser.

I hope resolved your problem reply back to me.

Thank you asked Questions in Mozilla support.

Modified by ARMAN KHAN

Helpful?

more options

Arman, Thank you very much. I stumbled around Preferences looking for a box to uncheck when I spotted an arrow within a box to change choice from never remember history which got me out of Private Browsing Always. I am new to all this and was unsure if my question had gone out. Hope this reply reaches you as I appreciate you taking the time to help as all has returned to my prior settings. Jim

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.