Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox hangs on "Checking for Updates"

  • 2 replies
  • 1 has this problem
  • 6 views
  • Last reply by FredMcD

more options

Subject line says it all.

Firefox has become unusable. These is no easy way to turn off automatic "Checking for Updates. Homepage and new tabs are set to Firefox Home and the "About Firefox" drop down shows "Checking for Updates" for several minutes everytime.

Microsoft Edge works just fine.

All Replies (2)

more options

It is possible that your security software is blocking the update check.

It is possible that (anti-virus) security software is causing the problem. Try to disable security software temporarily to see if that makes a difference.

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

If you have trouble with the upgrade, use this link; http://www.mozilla.org/en-US/firefox/all/


How do you completely turn off update checks in Firefox v64?
You can use a policies.json file to disable updates for all users.
https://github.com/mozilla/policy-templates/blob/master/README.md
or
https://winaero.com/blog/disable-updates-firefox-63-above/