Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I get "classic" context menu when I right-click on the menu bar?

  • 7 replies
  • 1 has this problem
  • 43 views
  • Last reply by jscher2000

more options

When I right-click on the menu bar I get the context menu with Customization, turning on/off menu&bookmarks bars etc.

I want a classic windows context menu instead, the one with restore/minimize/maximize/close...

How can I do that?


Thanks in advance!

Attached screenshots

Chosen solution

I guess I didn't read all the way down to your reply. Sorry about that.


Hi pike888, in order to get the window control menu when you right-click in the upper left corner, unfortunately you need to display the Title Bar. That's an option in the Customize panel.

As a workaround, can you get used to this:

Alt + Spacebar

That's a global keyboard shortcut across Windows apps.

Read this answer in context 👍 0

All Replies (7)

more options

hello pike,

follow the instruction and step:

Can you see the tab bar and main toolbar? If not:

Firefox might be in its full screen view. The F11 key switches between normal and full screen views. Some pop-up windows will not show the tab bar and the full main toolbar (just the address section). Such windows also will not usually have the menu bar. You can start a new window using Ctrl+n. Assuming you do not have those problems...

You can use one of these methods to show the toolbar list and select Menu Bar and/or Bookmarks Toolbar there:

right-click a blank spot on the tab bar (or the "+" button) tap the Alt key to activate the classic menu bar > View > Toolbars in Customize mode > Show/Hide Toolbars. [https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-a...] Success?

i hope resolve the problem then reply me.

Thank you!

more options

Hi pike888, why are you running Firefox 43???

The problem could be this bug in older versions of Firefox (possibly 29-54, but I can't remember):

After you use Customize, the right-click context menu for the Bookmarks menu (the one that drops from the classic menu bar) no longer works in that window.

If you launch a new window (Ctrl+n), it works normally there, unless/until you use Customize in that window.

more options

Hello pike,

I think this will help you

Can you see the tab bar and main toolbar? If not:

Firefox might be in its full screen view. The F11 key switches between normal and full screen views. Some pop-up windows will not show the tab bar and the full main toolbar (just the address section). Such windows also will not usually have the menu bar. You can start a new window using Ctrl+n. Assuming you do not have those problems...

You can use one of these methods to show the toolbar list and select Menu Bar and/or Bookmarks Toolbar there:

right-click a blank spot on the tab bar (or the "+" button) Tap The Alt Key To Activate The Classic Menu Bar> View > Toolbars in Customize mode > Show/Hide Toolbars (see: Customize Firefox controls, buttons and toolbars)

more options

hii pike888 Please follow these to get "classic" context menu when I right-click on the menu bar

 right-click a blank spot on the tab bar (or the "+" button)
   tap the Alt key to activate the classic menu bar > View > Toolbars.
   in Customize mode > Show/Hide Toolbars (see: Customize Firefox controls, buttons and toolbars)
more options

AMAN ARYAN said

Hi pike888, why are you running Firefox 43???

According to the system details, the OP is running Firefox version 77.0

more options

Thanks a lot guys.

Using all your advices I came to just one step to the solution and luckily I figured it out easily. :)

I had to enable TITLE BAR in customize menu (bottom left tick box).

Thank you all!

Modified by pike888

more options

Chosen Solution

I guess I didn't read all the way down to your reply. Sorry about that.


Hi pike888, in order to get the window control menu when you right-click in the upper left corner, unfortunately you need to display the Title Bar. That's an option in the Customize panel.

As a workaround, can you get used to this:

Alt + Spacebar

That's a global keyboard shortcut across Windows apps.

Modified by jscher2000