Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Middle-Clicking on a hyperlink is no longer opening new windows and I would like it do so.

  • 17 replies
  • 2 have this problem
  • 295 views
  • Last reply by pete39

more options

This is driving me nuts.

My desired behavior is that, when I middle-mouse-click on a hyperlink, Firefox launches a new window (not a tab) with that URL.

This is how it was working before a power interruption forced my computer to restart tonight, and my desired behavior has gone away.

The middle mouse button works for other functions; and, middle-clicking on bookmarks in my bookmark bar does launch a new window with that bookmark as expected. However, middleclicking a hyperlink does nothing.

I have browser.tabs.opentabfor.middleclick = false and in the options menu, "open links in tabs instead of new windows" is unchecked. Additionally I have set browser.link.open_newwindow = 2.

Can anyone help me here? This is driving me slightly batty.

Chosen solution

Here's the workaround. Sorry we didn't discover it last month. There was so little chatter about this change that it required some lengthy research to uncover the solution. (The change was made because some people needed a way to prevent anything from happening when middle-clicking a link.)

You can create a new preference to tell Firefox what to do if browser.tabs.opentabfor.middleclick is false, i.e., new window or nothing. On Linux and Android, it is pre-set to open in a new window, but on Windows and Mac, it defaults to doing nothing. Here's how you change that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste the new preference name

middlemouse.openNewWindow

If this preference was already created and has a value of false, double-click it to flip the value to true. Otherwise, continue with the next step.

(3) On the bar with the preference name, keep the radio button next to Boolean and click the + button to add the preference. Then Firefox should display the new value.

(4) If the new preference was not set to true automatically, double-click it to toggle the value to true.

Screenshot sequence attached for reference.

To summarize the expected result:

(1) New tab (no customization)

  • browser.tabs.opentabfor.middleclick => true
  • middle-click opens links in a new tab

(2) No effect (partial customization) -- on Windows and Mac

  • browser.tabs.opentabfor.middleclick => false, [middlemouse.openNewWindow => false]
  • middle-click on a link is ignored

(3) New window (full customization)

  • browser.tabs.opentabfor.middleclick => false, middlemouse.openNewWindow => true
  • middle-click opens links in a new window
Read this answer in context 👍 2

All Replies (17)

more options

Hi ShadowDragon8685,

  • Click on menu icon.
  • Click on options.
  • In left pane, you will find General menu.
  • In this menu, you will find an option Tabs.
  • Mark the checkbox Open links in tabs instead of new windows.

If it doesn't solved your problem, then feel free to ask in Reply Section. Thanks for raising your question in Reply Section.

Helpful?

more options

Hi shadowdragon,

let's dive into the details of which links and what they did before.

By default, Firefox diverts links that websites targeted to open in a new window to a new tab instead. (There are some exceptions where new windows are allowed.) Is that still working for you? You sometimes might need to click this checkbox to clear it and check it again on the Options page:


By default, other links open in the same tab. You can divert most of them to a new tab using these tricks:

Ctrl+click the link middle-click the link with the mouse scroll wheel right-click > Open Link in New Tab If you were used to ALL links opening in a new tab automatically, or all links on particular sites such as your search results, a setting or add-on might have gotten lost.

(1) Search results

Each search site generally has a setting for whether to open links in the same tab or in a new window/tab. This is generally saved in a cookie, so if you flushed your cookies, you'll need to reestablish that setting on the search site.

For example: https://www.google.com/preferences ("Where results open")

(2) All links on all pages

This requires an add-on. Maybe the one you were using stopped working? You could check the Add-ons page and see whether it is disabled or whether its Options need an update. Either:

Ctrl+Shift+a (Mac: Command+Shift+a) "3-bar" menu button (or Tools menu) > Add-ons type or paste about:addons in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions.

Then scan down the right side and find your tab-related extension(s) and check Options or click Enable if necessary.

If you need a new extension for this, see:

https://addons.mozilla.org/firefox/addon/open-link-with-new-tab/

It works with regular links, but might not work with scripted links.

Thank you

Helpful?

more options

Shashank Shekhar said

Hi ShadowDragon8685,
  • Click on menu icon.
  • Click on options.
  • In left pane, you will find General menu.
  • In this menu, you will find an option Tabs.
  • Mark the checkbox Open links in tabs instead of new windows.
If it doesn't solved your problem, then feel free to ask in Reply Section. Thanks for raising your question in Reply Section.

Is this an automated response? This is literally explaining how to make Firefox do the thing I explicitly said I did not want it to do. Did human eyes actually read my question and craft this answer?

Helpful?

more options

Himanshu prabhakar said

Hi shadowdragon, ... Thank you

NOT TABS! Not tabs! I hate tabs! I want new windows, NOT TABS!

Helpful?

more options

I feel like the first two answers literally did not read my problem, they just latched onto keywords and splattered boilerplate answers.

To reiterate:

When I middle-click a hyperlink, I want the link to open in a new window. I don't care what the hyperlink specifies; new window.

And now, somehow, settings have gotten even more wonky; middle-clicking a bookmark in the bookmark bar, etc, now navigates the current window to that website. What on earth?

Helpful?

more options

browser.tabs.opentabfor.middleclick = false works for me.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

more options

cor-el said

browser.tabs.opentabfor.middleclick = false works for me. Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Thank you for comprehending my problem and trying to help!

I'm still having trouble, though; middle-click for continuous scroll works, it works fine in other programs. But even with the DEFAULT theme active and safe mode active, middle-clicking a hyperlink does nothing, and middleclicking a bookmar button navigates the current window to that URL.

I'm wondering if some other, unknown setting, somehow got whongo'd.

Discovery: If I set browser.tabs.opentabfor.middleclick = true then middleclicks correctly launch in a new tab. But if I set it back to false then they do nothing.

Rightclicking and clicking 'open in new window' works properly. Could something be erroneously intercepting middleclick-launched windows as unwanted pop-ups? Though, that doesn't explain why bookmarks would launch in the same window either way...

Additionally, with browser.tabs.opentabfor.middleclick = false middleclicking a bookmark correctly launches a new tab. It's almost a pity that I loathe tabbed browsing.

An yes, I've tried this both with Firefox in and out of safe mode, and in and out of the default theme.

Modified by ShadowDragon8685

Helpful?

more options

Apologies if this is an impertinent suggestion, but...

How often do you want to open a new tab? If you never want a new tab, I have an add-on for that. It just takes any new tab that opens and detaches it to a new window instead. In case that sounds interesting:

https://addons.mozilla.org/firefox/addon/i-hate-tabs-sdi-for-firefox/

Helpful?

more options

jscher2000 said

Apologies if this is an impertinent suggestion, but... How often do you want to open a new tab? If you never want a new tab, I have an add-on for that. It just takes any new tab that opens and detaches it to a new window instead. In case that sounds interesting: https://addons.mozilla.org/firefox/addon/i-hate-tabs-sdi-for-firefox/

Basically never-ever, the only exception ever being occasionally an about:config or about:preferences.

I hate even having the tab-bar occupying vertical screen real-estate, and I had to jump through hoops to hide the damn thing.

[edit] Okay, having tested it, this does appear to be an effective workaround to ape the behavior I want, but since Firefox was doing what I wanted it to do natively, until suddenly and without explanation it does not, I don't really consider this to be a fix - something is wrong with my Firefox, and figuring out what, how, and fixing it, should be preferred, both for me and for future knowledge. I'll keep banging away on this, but I hope someone has some knowledge of some obscure setting that might have gotten flipped.

Modified by ShadowDragon8685

Helpful?

more options

Hello...

I plugged my mouse into another computer and it worked fine. So that lets me know its either something fishy with firefox or my computer.

As I was writing this I found out what my problem was. However I'm unsure of why. I'll explain here in case anyone else has a similar problem.

If I Middle click + Hold click for a solid second on the link it will open a new tab.

It just seems like there is a massive delay in my middle mouse click speed on this system.

Either way I'll investigate this further on my own. I appreciate all of your time.

thank you..

Helpful?

more options

Hi ShadowDragon8685,

this is not a problem of your personal config. I am experiencing exactly the same issue on all of my computers. Did the middle mouse config as well. So, they seem to have changed the code if you ask me. I am dying to get a solution for this pita. Anyone??

Jetmaster

Helpful?

more options

I have exactly the same problem. It broke after upgrading from 76.0.1. Toggling "browser.tabs.opentabfor.middleclick" or changing the "Open links in tabs instead of new windows" preference in Options (which now does absolutely nothing) used to do the right thing. Now it just prevents middle-click from doing anything. This is a huge loss to anyone used to using multiple or large screens. It is not a problem with the mouse driver (tried several types and brands) nor is it a problem with a particular Windows version (tested on Windows 7 and 10, both Home and Pro). I've tried every combination of settings about "middle" or "open.new" in about:config that I can think of to no avail, even with all addons disabled in safe mode.

The setting is, quite simply, broken.

Modified by pete39

Helpful?

more options

Maybe you have an extension that prevents opening a new tab or your software is blocking it.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.

Helpful?

more options

Chosen Solution

Here's the workaround. Sorry we didn't discover it last month. There was so little chatter about this change that it required some lengthy research to uncover the solution. (The change was made because some people needed a way to prevent anything from happening when middle-clicking a link.)

You can create a new preference to tell Firefox what to do if browser.tabs.opentabfor.middleclick is false, i.e., new window or nothing. On Linux and Android, it is pre-set to open in a new window, but on Windows and Mac, it defaults to doing nothing. Here's how you change that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste the new preference name

middlemouse.openNewWindow

If this preference was already created and has a value of false, double-click it to flip the value to true. Otherwise, continue with the next step.

(3) On the bar with the preference name, keep the radio button next to Boolean and click the + button to add the preference. Then Firefox should display the new value.

(4) If the new preference was not set to true automatically, double-click it to toggle the value to true.

Screenshot sequence attached for reference.

To summarize the expected result:

(1) New tab (no customization)

  • browser.tabs.opentabfor.middleclick => true
  • middle-click opens links in a new tab

(2) No effect (partial customization) -- on Windows and Mac

  • browser.tabs.opentabfor.middleclick => false, [middlemouse.openNewWindow => false]
  • middle-click on a link is ignored

(3) New window (full customization)

  • browser.tabs.opentabfor.middleclick => false, middlemouse.openNewWindow => true
  • middle-click opens links in a new window

Modified by jscher2000

Helpful?

more options

Hi ShadowDragon8685, did my reply from last Sunday work for you? If so, please mark it as the solution to your question so the forum will allow search engines to index it. I can see other people are still looking for the solution. Thanks.

https://support.mozilla.org/en-US/questions/1289787#answer-1330105

Helpful?

more options

jscher2000 said

Hi ShadowDragon8685, did my reply from last Sunday work for you? If so, please mark it as the solution to your question so the forum will allow search engines to index it. I can see other people are still looking for the solution. Thanks. https://support.mozilla.org/en-US/questions/1289787#answer-1330105

Hey, sorry about that. I had actually lost the password to my Firefox account and it was driving me nuts, and I was afraid I'd lose all my bookmarks and stuff like the warning said - that it was gonna wipe my browser. Then I found it.

Modified by ShadowDragon8685

Helpful?

more options

jscher2000 said

Here's the workaround. (3) New window (full customization)
  • browser.tabs.opentabfor.middleclick => false, middlemouse.openNewWindow => true
  • middle-click opens links in a new window

Thank you! That solved it for me as well.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.