Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Suddenly problems of seeing a mp4-video

  • 4 replies
  • 1 has this problem
  • 88 views
  • Last reply by AMAN ARYAN

more options

Hi. I had been able seeing lots my own mp4-video which has been uploaded years ago. Not all,

 -  but some of my videos now show a black window,  -  only able to hear the sound-track

www.birkevang.info/Video/England.mp4 show black window but www.birkevang.info/Video/Portugal.mp4 is ok

(If I download the 'black' video from Birkevang-homepage using FTP - the video is still ok on my own PC.)

Mysterious ! (Someone: Mozilla-Windows-xxx- may be had made an update some days/weeks ago  ??)

Chosen solution

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

   Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
   Select the Advanced panel and the General tab.
   Uncheck Use hardware acceleration when available.
   Close Firefox completely and then restart Firefox to see if the problem persists. 

In Firefox 55 and above:

   Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
   Select the General panel.
   Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
   Fx55Performance-disableHWA
   Uncheck Use hardware acceleration when available.
   Close Firefox completely and then restart Firefox to see if the problem persists. 

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

   Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems 
   Upgrade your graphics drivers to use hardware acceleration and WebGL 

Thank you.

Read this answer in context 👍 0

All Replies (4)

more options

Hi steen.billenstein, please ignore that spam message with a phone number. That is not official and we have no idea what they will do to your system if you engage with them.

Helpful?

more options

The video that doesn't play in mp4v: Codec: MPEG-4 Video (mp4v) The video that plays is avc1: Codec: H264 - MPEG-4 AVC (part 10) (avc1)

Maybe consider to re-encode this video in a supported format.

There is a bug report about supporting mp4v:

Please do not comment in bug reports

You can vote for a bug to show your interest

Modified by cor-el

Helpful?

more options

Thanks to all Helping People.

What I did, was to re-encode my video, and uploaded the new video to my own homepage. And now it's work.

In fact, I don't know the difference of the two codec. The first one has been made in 2015 with Pinnacle Studio 12 and the new one made to day Pinnacle Studio 19 ...

The surpricing question is: Why did the old one show ok until some weeks/month ago ??

Helpful?

more options

Chosen Solution

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

   Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
   Select the Advanced panel and the General tab.
   Uncheck Use hardware acceleration when available.
   Close Firefox completely and then restart Firefox to see if the problem persists. 

In Firefox 55 and above:

   Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
   Select the General panel.
   Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
   Fx55Performance-disableHWA
   Uncheck Use hardware acceleration when available.
   Close Firefox completely and then restart Firefox to see if the problem persists. 

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

   Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems 
   Upgrade your graphics drivers to use hardware acceleration and WebGL 

Thank you.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.