Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Cookies exceptions not working

  • 7 replies
  • 1 has this problem
  • 27 views
  • Last reply by Red-Herring

more options

Hello,

I'm having some problems with cookies exceptions. When I add cookies exceptions from Settings > Privacy & Security > Exceptions they do not work. When I add exceptions from that page - Page info > Permissions they work. I think there is something wrong with the Exceptions in the settings area or some hidden setting I don't see...

By default I am using private mode and blocking all cookies.

On attached image you can see first entry I added in the settings page and second from permissions menu in page info.

Would appreciate your help.

Thank you.

Attached screenshots

Chosen solution

Do you have "first party isolation" enabled? I think the address with ^ is related to that feature, but I couldn't tell you how those exceptions work.

Read this answer in context 👍 1

All Replies (7)

more options

hello Red herring,


In Exceptions, Firefox is particular about the protocol. You usually need to create both the secure and insecure versions:

A possibly more convenient way if you are dealing with first-party cookies is to use the Permissions panel of the Page Info dialog.

You can call that up using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Set Cookies" and uncheck the "Use default" box, and then select the permission you prefer. That change should show up in the Exceptions dialog.


i hope resolve the problem then reply me back


Thank you!

Helpful?

more options

Thank you but it doesn't.

I just clean system reinstall and I have bunch of exceptions in my notepad (Firefox doesn't allow to export/import them separately). Going to everyone one by one and adding it that way would be very time consuming.

Also I have added them the way you posted, even deleted every exception and tried that again - didn't worked. In my case its: http://joemonster.org https://joemonster.org

Thank you.

Helpful?

more options

Also make sure you only use the domain and not any extras appended like the highlighted item in your screenshot, but use the plain entry like shown just above that one.
Wildcards aren't supported, use the top level domain instead.

Helpful?

more options

Chosen Solution

Do you have "first party isolation" enabled? I think the address with ^ is related to that feature, but I couldn't tell you how those exceptions work.

Helpful?

more options

Do you possibly user containers ?

Helpful?

more options

Could be this bug:

  • Bug 1556212 - Per-Domain Cookie Permissions are broken with FPI enabled

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Helpful?

more options

Yes, disabling "privacy.firstparty.isolate" in "about:config" works.

Thank you very much.

Modified by Red-Herring

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.