Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

missing menus in menu bar on a mac

  • 6 replies
  • 1 has this problem
  • 102 views
  • Last reply by cor-el

more options

Hi There, Please see the attached image. As you can see there are no menus to select in the top menu bar. When i scroll through they drop down but show nothing or partial info.

Can you help? Is this a software or hardwear issue? I do not have this problem with any other software on my mac.

Attached screenshots

Chosen solution

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Read this answer in context 👍 1

All Replies (6)

more options

Chosen Solution

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Helpful?

more options

Hi FredMcD,

Many Thanks for your post and advice. This has solved the problem.

Please let me know next steps? I obviously have extention/add-on issues, right?

Cheers Richard.

Helpful?

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

more options

Hi FredMcD,

The hardware acceleration turn off seems to have done the trick.

Thanks for your help.

All the best Richard.

Helpful?

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

Helpful?

more options

Note that this is a known bug on Catalina.

  • Bug 1603956 - macOS Catalina: Menu labels missing when cold opening Firefox from link or other app

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.