Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Don't want to jump to new tab on context search or right click

  • 6 replies
  • 1 has this problem
  • 20 views
  • Last reply by McCoy

more options

When I right click on a link and choose "open in new tab" or highlight text and do a search from the context menu, can I set my preferences or about:config so that browser does not jump to the new tab immediately? In other words, I want to stay on the page I'm on and have the new link tab load in the background. I hope I have explained this adequately. Thanks.

Chosen solution

Just in case you haven't noticed :   I edited my last post .....

Read this answer in context 👍 0

All Replies (6)

more options

Hello pursuit81,

Would you try this please :

Type in the address bar   about:config   and press Enter.
(ignore the warning)

Type in the search bar an look for the preference :

browser.tabs.loadInBackground  and set its value to   true.

Then close and restart Firefox.

If you want to, you could also toggle these preferences :

browser.tabs.loadBookmarksInBackground
browser.tabs.loadBookmarksInTabs
browser.tabs.loadDivertedInBackground


Also go to Options => General => under Tabs :

uncheck :   "When you open a link in a new tab, switch to it immediately".

Helpful?

more options

Thank you very much. Your solution solves the problem of a link opening immediately in a new tab and I appreciate it but if I do a search from the context menu, that is, highlight some text and then right click and then choose "Search Google for 'whatever the text I have highlighted is', it still immediately jumps to a new tab. Is there a way to stop this from happening? Thx again.

Helpful?

more options

Would you give this a try :

On the "about:config" page, set the value of   browser.search.openintab   to   false.

Set the value of   browser.search.context.loadInBackground  to   true.

Any luck ?

Modified by McCoy

Helpful?

more options

Chosen Solution

Just in case you haven't noticed :   I edited my last post .....

Helpful?

more options

Sorry, work intervened and I could only just now get back to it. Yes! The change worked. Thanks very much.

Helpful?

more options

pursuit81 said

Yes! The change worked.
Thanks very much.

My pleasure   -   I'm so glad it worked !

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.