Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Password Required Pop-up delay

more options

Is there a way of making the Password Required Pop-Up pop-up sooner? I launch Firefox and start typing in search or address, while I am looking at the keyboard the Password Required pop-up appears on screen silently. I am typing away then find I am typing my search or filling in a form online into the pop-up! The arrival of the pop-up is random time wise, could arrive within seconds or maybe in 30 seconds or maybe longer.If the pop-up HAS to appear it should appear when you launch Firefox. I truly find this very annoying, having to re-type, then entering the password then going back to where I was before the pop-up!

Chosen solution

Firefox does require some time to fully launch; and that "time" depends upon 'when' Firefox is launched as far as how long that is. The first launch each day Firefox seeks out a lot more websites than it does later in the day, mostly due to Firefox looking for update availability for Firefox itself and a separate 'look' for updates for Add-ons for Firefox, including Add-ons that come with Firefox.

I avoid trying to make any keyboard entries for at least 60 seconds after launch to avoid an issue like that; and I don't even use the Master Password feature which sounds like your issue.

Read this answer in context 👍 0

All Replies (4)

more options

Chosen Solution

Firefox does require some time to fully launch; and that "time" depends upon 'when' Firefox is launched as far as how long that is. The first launch each day Firefox seeks out a lot more websites than it does later in the day, mostly due to Firefox looking for update availability for Firefox itself and a separate 'look' for updates for Add-ons for Firefox, including Add-ons that come with Firefox.

I avoid trying to make any keyboard entries for at least 60 seconds after launch to avoid an issue like that; and I don't even use the Master Password feature which sounds like your issue.

Helpful?

more options

Hi alan_woolidge, glad to see you on Mozilla Support Forum.

Literally i don't have any idea about delayed popup, it could be depend upon your system performance. So if it is annoying you, you can just turn off this option.

  • First click on menu icon.
  • Then, click on options.
  • In left pane, click on Privacy & Security menu.
  • Uncheck use a master password.

If it doesn't solved your problem, then feel free to ask in Reply Section. Thanks for raising your question in Mozilla Support Forum.

Helpful?

more options

You can consider to open the about:logins page to initialize the Password Manager. You can bookmark this page on the Bookmarks Toolbar for easy access.

Helpful?

more options

Thanks to all who have replied, I guess I will have a little more patience when starting up FF!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.