Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How can I completely disable those little video boxes that appear as I scroll?

  • 6 replies
  • 1 has this problem
  • 14 views
  • Last reply by cfcentaurea

more options

Since the last couple of FF updates, all of a sudden when I'm looking at a video on a page and I scroll down the page, a smaller version of the video pops up and scrolls down the page with me. It didn't do this before. I want to completely disable this feature, since I NEVER want to see a video following me as I am scrolling down the page (though I want it to keep playing so I can hear the audio). I couldn't figure out how to block this in about:config. Please tell me there's a way to do it - preferably without an add-on!

All Replies (6)

more options

Hi cfcentaurea, glad to see you in Mozilla Support Forum.

Does this occur on just one or two sites, or does it occur all over the place?

If it's just one or two sites, do you want to post a link to a page demonstrating this problem?

If you see it on multiple sites, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

   "3-bar" menu button > "?" button > Restart with Add-ons Disabled
   Help menu > Restart with Add-ons Disabled 

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

If it doesn't solved your problem, then let us know in reply section. Thank you for raising your question in Mozilla Support Forum.

Helpful?

more options

Hi Shashank Shekhar, thanks for your reply. This morning it happened on Facebook, but it has been happening on numerous other sites recently. I just tried FB in safe mode as you suggested but the scrolling video still pops up.

Helpful?

more options

Hello again cfcentaurea, after a lot of research i found an answer which will surely help you because i personally tried it and now it works for me.

  1. click on menu icon.
  2. then, click on options.
  3. then, In general option just uncheck Enable picture-in-picture video controls.

that's it, It will surely work for you.

Thanks for asking this question in Mozilla Support Forum.

Modified by Shashank Shekhar

Helpful?

more options

Generally speaking, Picture-in-Picture is a user option and site's can't hijack it.

What is more common is that sites monitor when you have scrolled past their player and then move the player back into view, for example, by fixing its position on the right side of the browser.

There isn't a general formula to block sites from doing that, but some add-ons let you hide annoying elements in pages, so that might work for some of them.

Helpful?

more options

Hi Shashank Shekhar - I'm afraid I already had that option unchecked. I don't see anything on https://support.mozilla.org/en-US/kb/about-picture-picture-firefox that actually tells you how to disable Picture-in-Picture itself, just how to enable or disable the toggle that appears on the Picture-in-Picture videos.

Helpful?

more options

Hi jscher2000, thanks for your reply. It just seems like this started happening all of a sudden starting with, I think, FF version 76, which makes me think it was something that was changed in FF and that there might be a setting I could change in about:config to get rid of them. I might be able to block the popup videos on individual websites with ublock (haven't tried it) but in many cases these are not sites I visit frequently, so to block them in specific sites won't really help.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.