Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Autoplay Setting can't make exceptions

  • 5 replies
  • 1 has this problem
  • 68 views
  • Last reply by Janell

more options

I usually have it set to block audio and video automatically, and when I'm watching actual videos on Youtube, yeah, I want autoplay turned off. BUT when I'm trying to just play some music, I'd like to allow it. However it's FOREVER TOGGLED OFF EVEN WHEN I SET IT TO ALLOW ALL AUDIO AND VIDEO. It will stay on for one song, and then turn it off again. I also can't allow an exception to that SPECIFIC website because it NEVER shows the blocking autoplay settings in the site info bar, and I can't manually add websites to the exceptions list. So I can't add youtube to my exceptions list, can't change the settings for the page, and even if I do it's NOT paying attention to my choice, even when set to allow for ALL websites.

Chosen solution

You aren't using Private Browsing mode ?

----

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 👍 1

All Replies (5)

more options

On some websites, the Autoplay permission doesn't display directly in the site information bar. Firefox sometimes only displays this permission if it detects a video trying to autoplay.

However, you can always change that setting by pressing the right arrow in the site information and pressing the More Information button at the bottom of the popup. That opens the Page Info screen. From there, you can select the Permissions tab and find the Autoplay permission listed there. Uncheck the Use Default checkbox and select the option that you want to use for YouTube.

That will also add YouTube to the exceptions list in the regular Firefox settings page.

Hope this helps.

Helpful?

more options

Hi! That worked for adding the allow audio and video specifically to the page (for others you press the right hand arrow next to connections and then the More Information panel is at the bottom, make sure the setting you choose is different from the main one, or it will remove the website from the exceptions list again).

However, the autoplay is still not functioning. It still turns back to off after it autoplays one video, continuous autoplay isn't working.

Helpful?

more options

Chosen Solution

You aren't using Private Browsing mode ?

----

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

more options

Hi! I wasn't in private browsing mode, but starting it in in safe mode DID get autoplay to work again. I'm going to disable them all and slowly add my apps back in one at a time and see which one is the culprit.

Helpful?

more options

Dug through things for a while, but I couldn't figure out which one caused it because it's working now! I cleaned up some older extensions just in case.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.