Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I hate the instrusive picture-in-picture function added to FireFox with no way to turn it off

  • 8 replies
  • 1 has this problem
  • 37 views
  • Last reply by pctek

more options

Some may like this feature, but I do not. Mozilla should given the user a way to turn this function completely off. All that has been posted is how to turn off the PIP control icon. Stop forcing us to accept the new features. Give us the option to say no and turn it off.

Chosen solution

Hi pctek, I'm also in the Bay Area.

So there's a script in the page watching the scroll position. If you scroll down past the big video, it tags a small player with the CSS class name adhesive-on and the style rules for that class stick it to the lower corner of the "viewport" (the viewable area of the page). I'm attaching a screenshot of the page with Firefox's Page Inspector tool open so you can see how the site does that.

So how do you block it? One possibility is if you use an extension like uBlock Origin, to use its feature for hiding or removing unwanted elements in web pages. Another is to use Stylus -- a general purpose web page restyling extension -- to hide the box. (I can explain how if you want to try that.) But either way, this is not due to the new PIP feature, it's one of the older tricks in the book.

Read this answer in context 👍 0

All Replies (8)

more options

Hello pctek,

Would you do this please :

Type in the address bar   about:config   and press Enter.
(ignore the warning)

Type in the search bar and look for the preference :

media.videocontrols.picture-in-picture.video-toggle.enabled
and set its value to   false.

Then close and restart Firefox.

I hope this will do the trick .....

Helpful?

more options

Hello McKoy. Your suggestion is all over the internet. All it does it turn off the small PIP widget. It does not turn off the actual P-I-P viewer window.

Modified by pctek

Helpful?

more options

Would you try this preference :

media.videocontrols.picture-in-picture.enabled    false.

Then close and restart Firefox.

Does that work ?

Helpful?

more options

Just to clarify, your Firefox is converting videos to PIP without you instructing it to do so by clicking the blue button? In that case, when you mouse over the PIP video, can you return it to its original location using the icon? I'm attaching a screenshot of the icon for reference.

If you have a pop-out video that doesn't behave like Firefox's built-in feature, maybe you have an add-on that can pop-out videos?

If you have a video following you down a page as you scroll, which isn't visible when you switch Firefox windows, I don't think that is the new PIP feature, I think it's an annoying behavior crappy sites have been using for a long time to keep ads and other videos in your face.

Helpful?

more options

Changing the value of the preference I mentioned in my second
post to   "false"  should disable the feature altogether.

Helpful?

more options

The configuration mod gets rid of the PIP widget, but the video continues to play in it's own window as I scroll down the page. The site is kpix.com Our local CBS station

Helpful?

more options

Chosen Solution

Hi pctek, I'm also in the Bay Area.

So there's a script in the page watching the scroll position. If you scroll down past the big video, it tags a small player with the CSS class name adhesive-on and the style rules for that class stick it to the lower corner of the "viewport" (the viewable area of the page). I'm attaching a screenshot of the page with Firefox's Page Inspector tool open so you can see how the site does that.

So how do you block it? One possibility is if you use an extension like uBlock Origin, to use its feature for hiding or removing unwanted elements in web pages. Another is to use Stylus -- a general purpose web page restyling extension -- to hide the box. (I can explain how if you want to try that.) But either way, this is not due to the new PIP feature, it's one of the older tricks in the book.

Helpful?

more options

Thank you jscher2000. I thought that might be the case when the same thing happened in Chrome and Edge. I did write (email) to the director of digital communications at CBS expressing my displeasure with them to allow the hidden code that prevents a user such as myself from turning it off. Thank you again

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.