Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Absolutely cannot get "Disable HTTP Cache" to work

  • 1 reply
  • 1 has this problem
  • 5 views
  • Last reply by cor-el

more options

I'm using Firefox Developer Edition while developing a website and that frequently involves making a change on the backend and refreshing the page to look at my changes. For some reason, however, I absolutely cannot get firefox to consistently reload the page completely FRESH and I cannot see changes that I have made unless I open the page in a completely new browser such as chrome/edge.

This is what I've tried:

Disable HTTP Cache (when toolbox is open) Shift-f5 ctrl-shift-r network.http.use-cache - set to false browser.cache.disk.enable and browser.cache.memory.enable - both set to false

Nothing seems to be working and I'm about to tear my hair out here. Is there anything else I can look at to confirm that these are not working? I've literally removed all my jQuery from a script block and it is all still visible. I can then open my page in Edge and the script block is empty.

All Replies (1)

more options

Note that Firefox uses Ctrl+F5 to bypass the cache, but ctrl-shift-r should work.

Are you making the changes in Firefox or on your website. It is possible that the page is cached elsewhere (like hosting server or your ISP) if Ctrl+F5 isn't working.

Does this also happen in a New Private Window or possibly "Forget About This Site" as that would rule out the Firefox disk cache?