Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

custom theme disappears as soon as home page fully loads

  • 6 replies
  • 1 has this problem
  • 13 views
  • Last reply by McCoy

more options

I downloaded the custom theme "CatNip_Cosmo" a few weeks, and it worked fine for a couple days. Now, it loads as soon as I open Firefox, but as soon as "Top Sites" and search bar loads, it reverts back to default 'theme', which is the grey grid. I'm using a new Dell PC running Windows 10. I haven't done anything different to Firefox homepage, changed any settings, or added any other extensions. It was fine one day and broken the next. I'm a little bummed because I really like having custom theme. Does anyone have any ideas as to why custom themes would suddenly stop working? Thank You! : )

Chosen solution

Hello Melon,

A mere stab in the dark   (and maybe even far-fetched),   but would you disable   "Firefox Color 2.1.5"  to see if that could be causing it ?

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

It also sounds a bit like this old bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1446183

Read this answer in context 👍 1

All Replies (6)

more options

Is the problem that Firefox is changing the theme selected on the Add-ons page as it's loading? Does it help to switch themes once or twice back to the one you like? You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Themes.

The currently enabled theme is at the top. To change to a different theme, scroll down to the one you want and click its Enable button.

Helpful?

more options

Thank you for responding, Jscher. Yes, Firefox changes the theme back to default upon loading. And the first thing I did was try other themes: same thing happened. I tried disabling then enabling each theme. Each new theme I tried stayed on as long as I didn't open a new tab. And when I closed Firefox and reopened it, the same thing happened. I only recently installed Firefox on this PC, so I haven't added any bling. And I went into settings and checked add-ons and extensions to make sure all settings were correct.

Helpful?

more options

Chosen Solution

Hello Melon,

A mere stab in the dark   (and maybe even far-fetched),   but would you disable   "Firefox Color 2.1.5"  to see if that could be causing it ?

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

It also sounds a bit like this old bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1446183

Helpful?

more options

I would disable "Firefox 2.1.5"" if I knew how....

Helpful?

more options

I Googled how to disable "Firefox Color", followed instructions, then restarted Firefox. There was no theme at all, only black, and my "Top Sites" disappeared and only the Firefox search box was there. So I went back into settings and enabled "Top Sites", and the custom theme, and VOILA! The custom theme loads and stays there even in new tabs, and so do all my top sites! Thank You SO much!!!! : )

Helpful?

more options

That was a lot of hassle you had to go through, but I'm glad
everything is back to normal.

Well done !

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.