Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In Privacy & Security, I manually delete cookies and history I do not want, I have always got down to 3 to 4MB, now it stays at 1GB, does not refresh.

  • 2 replies
  • 1 has this problem
  • 24 views
  • Last reply by a.cat1

more options

Win7, SP1, had Firefox 73+. Updated to 74.0 now to 75.0. Used to clear certain cookies and site history manually and get to 3 to 4 MB cache. Since 74.0 and now 75.0, under Privacy & Security, I clear some cookies and site history, but cannot get below 1GB in cache size. I can't find what has happened.

Chosen solution

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. (Firefox 57 and above) Click the Library button 57 library icon and choose History.
    (Click the menu button New Fx Menu and choose History in older Firefox versions.)
  2. In the History menu, choose "Clear Recent History...".
  3. Under "Time range to clear", select "Everything".
  4. Now, click the arrow next to Details to toggle the Details list active.
  5. From the details list, check Cache and Cookies and uncheck everything else.
  6. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. (Firefox 57 and above) Click the Library button 57 library icon and choose History.
    (Click the menu button New Fx Menu and choose History in older Firefox versions.)
  2. In the History menu, choose "Clear Recent History...".
  3. Under "Time range to clear", select "Everything".
  4. Now, click the arrow next to Details to toggle the Details list active.
  5. From the details list, check Cache and Cookies and uncheck everything else.
  6. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Helpful?

more options

Hi child_duckling, for some reason my earlier reply did not get posted. Your answer did provide a solution to my problem. The cache was reduced to 3.5MB, which is what I normally had after clearing the things I did not want to keep and then shut down the browser. I'm happy, but it just seems strange that this only showed up after update to 74.0, then in 74.01 and again in 75.0.

But then again, I have been told that I would complain if "they" hung me with a brand new rope. Thanks so much.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.