Search Support

can't load website "chessfriends mobile" properly in firefox

more options

hello, i am new here.

like the title says, i cannot load the website https://www.chessfriends.com/mobile#2 properly. some things are missing, like challenges from other players.

other browsers edge/i.e./chrome/opera are working good, only firefox has this issue. windows 10 desktop pc

i appreciate if someone could help, sorry for my bad english. greetings.

Chosen solution

oke i fixed this problem by myself using an extension: https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher-revived/

now it works with this extension i still don't know what the issue is on firefox.

Read this answer in context 👍 0

All Replies (12)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop

Helpful?

more options

thank you for replying,

i tried safe mode, the problem still exists. you can try out the site, and see it yourself. you don't have to login or so. it is just a chess site, no harmfull site.

more suggestions always welcome.

Helpful?

more options

I checked out the link and it loaded fine.

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

i just restarted my pc in safe mode with network support as you mentioned, still the same.

what do you mean by "try secure websites", is that the shield icon next-left by the lock icon on the adress bar?...i tried enable/disable that, but didn't help.

thanks anyway, maybe other suggestions?

Helpful?

more options

my apologies for double posting,

i made a video and uploaded to youtube: https://www.youtube.com/watch?v=Q7tSmamCWlM&feature=youtu.be

you can see player challenges from other players on chrome, but firefox doesn't show the challenges.

Helpful?

more options

https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any settings.

Helpful?

more options

i tried that, but it didn't help.

this issue is since a year ago, i did a lot of reading, and i tried a lot of things, it is not a big deal because other browsers works perfectly on this chess site. maybe something to do with flash player, i tried re-install it to latest version, didn't help.

my old pc had the same issue, fresh windows install etc. didn't help. i appreciate any other suggestions.

Helpful?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

more options

thank you for support, i tried clear cache, safe mode, reload as you mentioned, did other things, it didn't help.

i uploaded another video on youtube: https://www.youtube.com/watch?v=eCQrV_SLpmM&feature=youtu.be

other suggestions are always welcome.

Helpful?

more options

Chosen Solution

oke i fixed this problem by myself using an extension: https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher-revived/

now it works with this extension i still don't know what the issue is on firefox.

Helpful?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Helpful?

more options

thank you for the help, i flagged the post as solved problem. it would be better if it worked without the add-on/extension. but i am happy with it.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.