Search Support

Website font size much smaller in Firefox than Safari or Chrome

  • 5 replies
  • 1 has this problem
  • 12 views
  • Last reply by John

more options

Hi, on my system Firefox displays page fonts much smaller than the same page in either Chrome or Safari. This is across multiple sites. Zoom set to 100% in all three. My Firefox "Allow pages to choose their own fonts, instead of your selections above" is checked.

Attached screenshot of same page in all three.

Catalina 10.15.4 -- Latest versions of all three browsers -- Firefox 74.0 (64-bit) Thanks much, John

Attached screenshots

Chosen solution

You can change the font and the size in your about:preferences. Just scroll to Language and Appearance (see screenshot)

Read this answer in context 👍 0

All Replies (5)

more options

Chosen Solution

You can change the font and the size in your about:preferences. Just scroll to Language and Appearance (see screenshot)

Helpful?

more options

Thanks but I'd rather know why Firefox (in general, or maybe a bad config in my system) isn't displaying websites as their designers intended.

Thanks again, John

Helpful?

more options

Hi John, Firefox normally tries to follow system text size settings. I'm attaching a comparison from Windows 10 (Chrome/old Edge/Firefox). The font rendering differs, but the size seems fairly consistent.

I wonder whether it is something specific to Mac / Catalina?

Do you use the privacy.resistFingerprinting setting? That can have peculiar effects on zoom level.

Helpful?

more options

Does Firefox use the same font and font settings as the other browsers?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.


Firefox 73+ comes with a Zoom section in "Options/Preferences -> General -> Language and Appearance" to set the default zoom setting.

Helpful?

more options

Thanks everyone - based on your various responses I ended up just adjusting the default font size - my Firefox was 13 and Chrome was 16, for instance (that took a bit of digging as Chrome just displayed it as "Medium (Default)"

It's a plain vanilla new FF install so I guess, maybe (again, unless I got a bad install) Firefox on Mac defaults to a smaller font size? That, combined with my complete disbelief that big sites like Wikipedia and The New York Times apparently don't specify a default text size...? WTH? :-)

Anyway, I'm thrilled to be back home tooling around the web with my trusty Netscape Navigator...whoops I mean Firefox. Actually - wouldn't mind being back in innocent 1995 right about now... Peace and good health all around! John

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.