Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox has the wrong user-agent set

  • 6 replies
  • 1 has this problem
  • 82 views
  • Last reply by user2392987

more options

It looks like Firefox has the wrong user-agent set. I've made a few changes to about:config that I found on privacytools.io but none of them had anything to do with the user-agent. I read through Mozilla's "reset the default user-agent" article but none of the mentioned settings are in my about:config so there's nothing to reset. I would create them myself but I don't know what they should be set to (the article only says to click the "reset" button next to them). I'm running Ubuntu Linux but it seems Firefox is telling websites I'm running Windows...for proof see the screenshot attached to this post.

Hmm...it seems this page detected that I'm running a variation of Linux although no other pages (such as the one in the screenshot) could. What can I do?

Edit: it looks like this page says my user agent is correct (it shows Linux), however many many other sites on the internet say I'm running Windows. I'm really confused now.

Attached screenshots

Modified by user2392987

Chosen solution

Are you possibly using Resist Fingerprinting?

When Resist Fingerprinting is enabled then some items are spoofed (TimeZone: UTC, UserAgent: Firefox 68 ESR).

You can check this pref on the about:config page to see if Resist Fingerprinting is enabled and if this pref is user set (bold) reset to false via the right-click context menu.

  • privacy.resistFingerprinting = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 1

All Replies (6)

more options

Helpful?

more options

FredMcD said

Does this help: https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox http://www.howtogeek.com/113439/how-to-change-your-browsers-user-agent-without-installing-any-extensions/

I mentioned in my original post that I tried following the steps in the first article but could not.

The second one, however, is helpful. Now I know how to forcefully change my user-agent but I have no idea what it should be. The site HowToGeek’s article links to has all sorts of samples but none are what I’m looking for and I don’t know what to change to make it so. I’m running Ubuntu 19.10 and the latest version of Firefox - do you know what I could put in the general.useragent.override setting at about:config?

Modified by user2392987

Helpful?

more options

https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox Look for: Reset the default Firefox user agent

Does that work?

Helpful?

more options

jacobsimone12 said

Edit: it looks like this page says my user agent is correct (it shows Linux), however many many other sites on the internet say I'm running Windows. I'm really confused now.

When you click on "More system details" you will see :

More Information

Application Basics


Name: Firefox Version: 74.0 Build ID: 20200309095159 User Agent: Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0

Helpful?

more options

Chosen Solution

Are you possibly using Resist Fingerprinting?

When Resist Fingerprinting is enabled then some items are spoofed (TimeZone: UTC, UserAgent: Firefox 68 ESR).

You can check this pref on the about:config page to see if Resist Fingerprinting is enabled and if this pref is user set (bold) reset to false via the right-click context menu.

  • privacy.resistFingerprinting = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

more options

cor-el said

Are you possibly using Resist Fingerprinting? When Resist Fingerprinting is enabled then some items are spoofed (TimeZone: UTC, UserAgent: Firefox 68 ESR). You can check this pref on the about:config page to see if Resist Fingerprinting is enabled and if this pref is user set (bold) reset to false via the right-click context menu.
  • privacy.resistFingerprinting = false
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

That did it! Thank you!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.