Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how do i delete old passwords

  • 20 replies
  • 1 has this problem
  • 31 views
  • Last reply by McCoy

more options

Firefox has begun showing multiple password options when I am trying to log into a site. Several errors (and yes, I consider them ERRORS) are occurring:

1) Firefox presents passwords for EVERY account I have on the current website, not just the one I have entered in the UserID field;

and

2) Firefox presents multiple, previous versions of the password for the correct UserID.

I want this to stop, mainly because, before these errors were introduced, only the correct version of the correct UserID's password was auto-populated, and pressing the LOGIN button was all that was required.

All Replies (20)

more options

Are you using a password add-on or other program?

Open the Password Manager and remove any unwanted entries.

more options

Hello Joe's Firefox Account,

Would you try this please :

Type in the address bar about:config and press Enter (ignore the warning)

Type in the search bar and look for the preference :

includeOtherSubdomainsInLookup

If it's value is true, change it to false.

If you had to change the value, then close and restart Firefox.

Any difference ?

Modified by McCoy

more options

If you want to delete old passwords :

You can have Lockwise and still be able to view/change/delete entries like you used to with the old passoword manager :

Type in the address bar :

chrome://passwordmgr/content/passwordManager.xhtml

Press Enter and maximize the window.

When you highlight an entry you will see a "Show Password" button at the bottom.

(you could bookmark this page)

more options

includeOtherSubdomainsInLookup fiuxed the problem with showing older versions of the saved passwords, but it is still showing a list of choices from other accounts saved for that site. For example, consider site XYZ.COM, where I have saved logins for three different user ids, AAA, BBB, and CCC. If I enter BBB in the Userid field and tab to the Password field, Foxfire insists on giving me a popup list where I have to select from the passwordB, and CCC. In the past (I do not recall how far back), this never happened. Firefox would simply populate the password field with the password matching the entry in the user id field.

How can I get this behavior back?

more options

Let me see if I get this right (I may be misconstuing what you're saying):

When you have entered a username, you get a dropdown with other (wrong) usernames (?)

Would you try this please :

Highlight an entry in the drop-down list using the cursor Down key (arrow key).

(Don't click the mouse and don't press Enter)

Press the Shift + Delete keys to delete the highlighted entry.

Repeat till only the correct username is left.

(Don't click the mouse and don't press Enter)

(Hovering with the mouse no longer works)

Does that work for you or does it not even come close to what the problem is ?

more options

When the username and password aren't entered on the same page, but the password is entered on the next page like for instance Gmail does then Firefox won't fill the password and you will have to select the username from the drop-down list to get the matching password.

You can use the search bar in Lockwise and remove outdated or mistyped username and password entries.

more options

This happens when the userid and password fields are on the same page.

However, your assertion that, in cases where they ARE on different pages, Firefox will not populate the password field is incorrect. GMAIL specifically populates the password field properly.

more options

McCoy said

Let me see if I get this right (I may be misconstuing what you're saying): When you have entered a username, you get a dropdown with other (wrong) usernames (?) Would you try this please : Highlight an entry in the drop-down list using the cursor Down key (arrow key). (Don't click the mouse and don't press Enter) Press the Shift + Delete keys to delete the highlighted entry. Repeat till only the correct username is left. (Don't click the mouse and don't press Enter) (Hovering with the mouse no longer works) Does that work for you or does it not even come close to what the problem is ?

Will this actually delete the "incorrect "passwords from the stored logins database, or just keep them from showing up here? The other login ids in the dropdown are not "incorrect" passwords, they just do not match the ID I've entered in the userid field. I do not want to actually delete them from the stored logins database

more options

What I posted will remove incorrect usernames, which
you don't want to save .....

more options

Then, no. This does not address my problem in the slightest. In the attached screenshot, "svdba" has been entered in the userid field. In the password field, Firefox is displaying password options for the "svdba" and "lorojo" userids. "lorojo" is another valid userid for this website for which I have a password stored. I DO NOT WANT TO DELETE IT FROM FIREFOX'S STORED-LOGIN DATABASE. I just do not want it to display in this dropdown when "svdba" (or anything else, actually) has been entered in the userid field.

In fact, in this situation, Firefox should be automatically populating the password field as soon as I tab to it, and not offering up a dropdown box at all.

IT USED TO WORK LIKE THAT.

more options

Did you check in "Options/Preferences -> Privacy" that the logins autofill setting is enabled to see if that makes a difference ?

more options

If the problem is bad enough, I suggest using a form--fill add-on. They can be set for global and specific websites.

more options

FredMcD: I simply want the thing to do correctly what it used to do for years.

more options

Joe's Firefox Account said

In fact, in this situation, Firefox should be automatically populating the password field as soon as I tab to it, and not offering up a dropdown box at all.

IT USED TO WORK LIKE THAT.

Well, things change .....

When I look at your screenshot : all you have to do is click on the second option, and Firefox should fill in your password and you can login.

(I assume that this doesn't happen with your bank only and/or if "lorojo" is a subdomain ?)

more options

I know I can simply click on the correct id name and it will populate the correct password. My point is that if Firefox didn't have this freakin' BUG, I wouldn't have to do that!

For what possible reason is Firefox showing me the stored passwords for ALL of the userids I have on any given website?? Especially when I've already identified the correct one by typing into the userid field?

"WELL THINGS CHANGE" HAH! Yeah, they do. And they're called BUGS! Mozilla should FIX THIS! But I guess you get what you pay for.

more options

Would you please take another look at my first post in this thread ?

Your response still puzzles me - did it, or did it not fix the problem  ?

One minute I'm thinking that you are talking about subdomains; next minute I think that you're talking about incorrect usernames ......

I just don't know what else to suggest anymore - I am so sorry.

But one thing you and I agree on : change isn't always a good thing.

more options

The problem you have understanding my responses is that there were two different responders to my question.

FredMcD told me to go into the password manager and delete the unwanted entries. This was totally 100% wrong answer that showed no understanding of the problem. I do not want to delete any entries from the saved login database. I only want the saved passwords for userids not entered into the current login page's userid field to not show up in a dropdown box in the password field. If the feature were working correctly, there wouldn't even be a dropdown box when the user has entered a value in the userid field.

Your first response talked about includeOtherSubdomainsInLookup. Setting this to false did remove part of the original problem (showing previous passwords for the same userid (i.e. "SVDBA" and "SVDBA - 12/14/2018" and "SVDBA - 04/09/2019"). But it still leaves the other part of the problem, where it shows password entries for every different userid I have associated with the given login page (i.e. "SVDBA" and "LOROJO"), even though I have typed "SVDBA" into the userid field of that login page. This is what I am sill trying to solve.

more options

I just found this bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1601558

Please make sure that you read the whole report; you may find it very interesting !

more options

Interesting? Perhaps, but hardly useful. If a user has already entered a username into the current login page, I'd say that pretty much settles it as to which username he desires. So offering passwords from different usernames (from that or any other subdomain) is just plain wrong; its a bug (intentional or not). Listing different usernames would make sense only if the username field had been left blank.

more options

Joe's Firefox Account said

its a bug

Hence the bug report .....


I don't know what else I can say; I hope that someone else will come up with an answer that you'll be happy with (or at least contented).