Search Support

Why does pressing the number 5 cause Firefox to refresh the page?

  • 10 replies
  • 3 have this problem
  • 47 views
  • Last reply by Renen

more options

Some of the time, but not all the time, Firefox will refresh the page I'm on when I press the number 5 on my Macbook Pro (tested on 2019 and 2015). I'm using the latest version of Firefox and it's been like this for a while. This gets really annoying when I need to type the number 5 at the end of a long form and it just refreshes the page.

I know that F5 reloads the page but there is no chance of me pressing F5 since I would need to hold the Fn key and press the touchbar to do this. I've also logged my keys to make sure that F5 wasn't being registered somehow.

Modified by bradley.weiers

All Replies (10)

more options

Is that the number 5 on a keypad or the 5 as normally present on the top row of the knowledge base.

In case of the former you can try to enable numlock if you have this feature on your keyboard.

Modified by cor-el

Helpful?

more options

Not the numpad, it's the regular horizontal numbers above the alpha keys on a laptop keyboard with no numpad.

Helpful?

more options

Does anyone know how I can log what Firefox is receiving and what it's doing under the hood so I can try and debug this?

Helpful?

more options

bradley.weiers said

Does anyone know how I can log what Firefox is receiving and what it's doing under the hood so I can try and debug this?

Hmm, there are keyloggers used in spyware, but I don't know if there is a friendly keylogger that only shows you the data.

Reloading the page will terminate any running script in the page, so it might make more sense to use a system-level app.

It's unfortunate the form doesn't have one of those warnings about leaving the page and losing your work. If you disabled those warnings in about:config, you might want to re-enable them while sorting out this issue. See:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste unlo and pause while the list is filtered

(3) If the dom.disable_beforeunload preference is bolded and has a value of false true, double-click it to restore the default value of true true

Modified by jscher2000

Helpful?

more options

Hello Bradley,

I'm just curious :

In order to make the F5 key reload the page, you have to press the Fn key.

This means, that that key has another function as well, and I wonder what symbol that key has and what it does when you press the key without pressing Fn (?)

Helpful?

more options

jscher2000 said

(3) If the dom.disable_beforeunload preference is bolded and has a value of false, double-click it to restore the default value of true

It does have a value of false but it is not bolded.

Helpful?

more options

bradley.weiers said

jscher2000 said
(3) If the dom.disable_beforeunload preference is bolded and has a value of false, double-click it to restore the default value of true

It does have a value of false but it is not bolded.

I'm sorry, I wrote that backwards. You want it to be false. But I guess the site where the form reloaded doesn't have protection against that.

Helpful?

more options

McCoy said

Hello Bradley, I'm just curious : In order to make the F5 key reload the page, you have to press the Fn key. This means, that that key has another function as well, and I wonder what symbol that key has and what it does when you press the key without pressing Fn (?)

The new Macbook Pros have a Touch Bar that has contextual buttons based on the application you're in. At that spot there is just a huge button to enter the search bar when the Fn button is not pressed. Just in case, I've disabled the Touch Bar to see if that fixes it.

Helpful?

more options

bradley.weiers said

The new Macbook Pros have a Touch Bar that has contextual buttons based on the application you're in. At that spot there is just a huge button to enter the search bar when the Fn button is not pressed. Just in case, I've disabled the Touch Bar to see if that fixes it.

    Thank you for the detailed explanation - much appreciated !

Helpful?

more options

I think I have a similar problem - https://support.mozilla.org/en-US/questions/1287114 but mine does it with a lowercase t. Possibly you can try with firefox version 64 and then 65 and see if it goes away - I don't know the answer myself but maybe its the same question!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.