Search Support

No Browser History Being Retained

  • 16 replies
  • 1 has this problem
  • 51 views
  • Last reply by user1321319

more options

Hello,

Having the same issue with a new Win 10 Pro that I just bought and having same issue as before that I had for a long time and gave up. Firefox still does not retain my browser history. Perplexed.

Thanks in advance for any fix. I'm using FF 73.0

Steven

Attached screenshots

All Replies (16)

more options

Do you have private browsing mode turned on?

Helpful?

more options

No I do not.

Helpful?

more options

You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Helpful?

more options

Thanks Fred. But there is no: commands like this at the bottom of this page. And why would one want to Clear History When FF Closes? Isn't that the opposite of my issues.

'At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.'

Helpful?

more options

That's near the bottom of the History section.

Helpful?

more options

Sorry it is not....

Helpful?

more options

Sorry it's not there where you describe...

Helpful?

more options

Look here;

Helpful?

more options

StevenB said

Sorry it's not there where you describe...

I think because you have NOT set Firefox to clear history when it closes, we can move on to the next possible issue.

Are you able to add new bookmarks successfully?

If you have problems with both history and bookmarks, please try the "Verify Integrity" function. That's here:

Open Firefox's Troubleshooting Information page using any of these methods:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Near the bottom, there is a section titled Places Database -- that's the file which stores history and bookmarks. Click the button labeled Verify Integrity. There may be a 10-15 second delay before results appear.

If all is well, the report that appears below the button should start with:

> Task: checkIntegrity
+ The places.sqlite database is sane
+ The favicons.sqlite database is sane

Does yours say that, or something else? You can select and copy the report, and then paste it into a reply for review and comment.

Helpful?

more options

FredMcD said

Look here;


I'll try that, thanks....can't hurt.

Steven

Helpful?

more options

jscher2000 said

StevenB said
Sorry it's not there where you describe...

I think because you have NOT set Firefox to clear history when it closes, we can move on to the next possible issue.

Are you able to add new bookmarks successfully?

If you have problems with both history and bookmarks, please try the "Verify Integrity" function. That's here:

Open Firefox's Troubleshooting Information page using any of these methods:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Near the bottom, there is a section titled Places Database -- that's the file which stores history and bookmarks. Click the button labeled Verify Integrity. There may be a 10-15 second delay before results appear.

If all is well, the report that appears below the button should start with:

> Task: checkIntegrity
+ The places.sqlite database is sane
+ The favicons.sqlite database is sane

Does yours say that, or something else? You can select and copy the report, and then paste it into a reply for review and comment.


Went through your instructions all is fine it appears.

Helpful?

more options

FredMcD said

You may be in Private Browsing mode or told Firefox not to remember. Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings. Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


I'll try it...and see what remains for the next day or two if anything. If this does work, what does that indicate to you?

Helpful?

more options

By the way, while I have your attention, if you don't mind giving me a hint on another FF matter, my Find In Page' not working. No Find box appears on the lower left.  ? Any clue or lead as to what this is. I use it a lot.

Thanks so much!!

Helpful?

more options

StevenB said

. . . . my Find In Page' not working.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Helpful?

more options

I had an other unrelated issue where my 'Find In Page' word search feature hasn't been working (I just got this new updated computer --new hard drive, upgraded to Win 10 Pro, etc, new softwares). Between this issue and the History issue I did a scrub clean reinstall of Firefox. That fixed the Find In Page issue. I will wait a day or so after my history populates and I change over/flip over to a new day and see if the reinstall fixed it.

Thanks Fred! Much much thanks!

Steven

Helpful?

more options

Please choose the correct solution so that this question can be properly archived.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.