X
Tap here to go to the mobile version of the site.

Support Forum

Unable to load external applications from Firefox, such as Zoom and Teamviewer

Posted

After the latest Firefox update, several websites I use that launch applications installed on my PC are no longer working. Zoom meetings is one of them, Teamviewer, and Solarwinds Take Control, OneDrive sync - anything really. I've tried uninstalling Firefox, removing all user data, and reinstalling but it is the same. Other browsers such as Chrome and the new Edge are working fine as expected.

After the latest Firefox update, several websites I use that launch applications installed on my PC are no longer working. Zoom meetings is one of them, Teamviewer, and Solarwinds Take Control, OneDrive sync - anything really. I've tried uninstalling Firefox, removing all user data, and reinstalling but it is the same. Other browsers such as Chrome and the new Edge are working fine as expected.

Chosen solution

If you aren't prompted then this would suggest that the link doesn't use this specific protocol because only a protocol link will trigger such a request to choose the application.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

Data Selfie DownThemAll Facebook Container Honey LastPass Privacy Badger Reddit Enhancement Suite RescueTime for Firefox uBlock Origin Webroot (disabled) Ghostery (disabled)

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

More Information

Eve
  • Top 25 Contributor
  • Administrator
63 solutions 391 answers

If you go to about:preferences#general and scroll down to Applications what do you see? There should be entries for these third party applications, like mine says "Zoommtg --> Use zoom meeting (default)"

If you go to about:preferences#general and scroll down to Applications what do you see? There should be entries for these third party applications, like mine says "Zoommtg --> Use zoom meeting (default)"
Was this helpful to you?
Quote

Question owner

They were there before I reset Firefox, still wasn't working though. Since I've reinstalled and refresh there are only a couple of entries. Can I add them back manually?

They were there before I reset Firefox, still wasn't working though. Since I've reinstalled and refresh there are only a couple of entries. Can I add them back manually?
Was this helpful to you?
Quote

Question owner

I also tried launching a Word doc in the desktop app from Sharepoint online and doesn't work either.

I also tried launching a Word doc in the desktop app from Sharepoint online and doesn't work either.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17863 solutions 161642 answers

when you use the refresh feature in Firefox then a new profile is created and some personal data (bookmarks and history, Form Data, tabs) is automatically imported. The current Firefox profile folder will be moved to an "Old Firefox Data" folder on the desktop.

It is possible to recover data from the "Old Firefox Data" folder on the desktop, but be cautious not to copy corrupted files to avoid carrying over problems.

For the file actions listed in "Options/Preferences -> General -> Applications" you would have to restore the handlers.json file to the current profile folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

when you use the refresh feature in Firefox then a new profile is created and some personal data (bookmarks and history, Form Data, tabs) is automatically imported. The current Firefox profile folder will be moved to an "Old Firefox Data" folder on the desktop. It is possible to recover data from the "Old Firefox Data" folder on the desktop, but be cautious not to copy corrupted files to avoid carrying over problems. For the file actions listed in "Options/Preferences -> General -> Applications" you would have to restore the <b>handlers.json</b> file to the current profile folder. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Folder/Directory:<br>Windows: Open Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles
Was this helpful to you?
Quote

Question owner

Ok great, thank you for that. I've restored them but it hasn't made any difference. This is how it was before I refreshed.

For example, when trying to open a word document from Sharepoint, I'm presented with a page that says "this address wasn't understood" and it has the ms-word: uri in the address bar. This is despite the ms-word handler showing up in preferences.

Ok great, thank you for that. I've restored them but it hasn't made any difference. This is how it was before I refreshed. For example, when trying to open a word document from Sharepoint, I'm presented with a page that says "this address wasn't understood" and it has the ms-word: uri in the address bar. This is despite the ms-word handler showing up in preferences.
Was this helpful to you?
Quote
brianroy86 0 solutions 4 answers

I'm running into the same issue with Zoom and Firefox on Ubuntu. I click a link to open a room, and it just sits there. It loads up fine in Chrome, and also works fine in Firefox on Windows. I need Zoom for work daily so this is a pretty big issue. It is the last thing keeping me from moving 100% away from Chrome to Firefox.

I'm running into the same issue with Zoom and Firefox on Ubuntu. I click a link to open a room, and it just sits there. It loads up fine in Chrome, and also works fine in Firefox on Windows. I need Zoom for work daily so this is a pretty big issue. It is the last thing keeping me from moving 100% away from Chrome to Firefox.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8958 solutions 73399 answers

Hi timfoote, could you try creating a new preference for ms-word and see whether that helps. Here's how:

(0) Select (triple-click is fastest) and copy this new preference name

network.protocol-handler.external.ms-word

(1) In a new tab, type about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, paste the new preference name

If this is already set up, Firefox should show a bar for the preference with either true or false. If it is false double-click it to switch it to true. If you don't see that bar:

(3) Firefox should show a bar with the choices Boolean, Number, and String. Click Boolean then click the + button at the right end of that bar.

(4) If Firefox doesn't set the value to true automatically, double-click the new preference to switch the value to true

Does Firefox handle the links any better now?


Hi brianroy86, when I hit a Zoom link in Firefox on Windows, the site pushes a download which I then have to launch outside of Firefox. Are you getting a background download that you can launch?

Hi timfoote, could you try creating a new preference for '''ms-word''' and see whether that helps. Here's how: (0) Select (triple-click is fastest) and copy this new preference name <pre>network.protocol-handler.external''.''ms-word</pre> (1) In a new tab, type '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, paste the new preference name ''If this is already set up, Firefox should show a bar for the preference with either'' '''true''' ''or'' '''false'''''. If it is'' '''false''' ''double-click it to switch it to'' '''true'''''. If you don't see that bar:'' (3) Firefox should show a bar with the choices Boolean, Number, and String. Click Boolean then click the + button at the right end of that bar. (4) If Firefox doesn't set the value to true automatically, double-click the new preference to switch the value to true Does Firefox handle the links any better now? ---- Hi brianroy86, when I hit a Zoom link in Firefox on Windows, the site pushes a download which I then have to launch outside of Firefox. Are you getting a background download that you can launch?

Modified by jscher2000

Was this helpful to you? 0
Quote

Question owner

Hi jsher2000, thanks for that, unfortunately it doesn't solve the problem. I still get "this address wasn't understood" when trying to open a word document, with the address bar showing: ms-word:ofe|u|https://sharepointaddress

Hi jsher2000, thanks for that, unfortunately it doesn't solve the problem. I still get "this address wasn't understood" when trying to open a word document, with the address bar showing: ms-word:ofe|u|https://sharepointaddress
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17863 solutions 161642 answers

Did you check for issues the new Firefox launcher process ?

Try to launch Firefox with the -no-deelevate command line switch.

See:

Did you check for issues the new Firefox launcher process ? Try to launch Firefox with the <b>-no-deelevate</b> command line switch. See: *https://support.mozilla.org/en-US/kb/windows-administrator-launcher-process-error-fix
Was this helpful to you?
Quote

Question owner

cor-el said

Did you check for issues the new Firefox launcher process ? Try to launch Firefox with the -no-deelevate command line switch. See:

I tried this, and the word app launched successfully from Sharepoint. But Zoom and other apps still aren't working. I restarted Firefox without the swith and word still launches ok, so that made me think adding network.protocol-handler.external.ms-word and the restart fixed that bit. So I added one for the zoommtg uri handler however can't replicate the same result, still doesn't work.

''cor-el [[#answer-1295317|said]]'' <blockquote> Did you check for issues the new Firefox launcher process ? Try to launch Firefox with the <b>-no-deelevate</b> command line switch. See: *https://support.mozilla.org/en-US/kb/windows-administrator-launcher-process-error-fix </blockquote> I tried this, and the word app launched successfully from Sharepoint. But Zoom and other apps still aren't working. I restarted Firefox without the swith and word still launches ok, so that made me think adding network.protocol-handler.external.ms-word and the restart fixed that bit. So I added one for the zoommtg uri handler however can't replicate the same result, still doesn't work.
Was this helpful to you?
Quote
brianroy86 0 solutions 4 answers

No background download. I already have zoom installed and it launched fine in chrome. And this is Linux, not windows. I tried the zoommtg parameter and that didn’t work, I also don’t have zoom under applications in about:preferences.

No background download. I already have zoom installed and it launched fine in chrome. And this is Linux, not windows. I tried the zoommtg parameter and that didn’t work, I also don’t have zoom under applications in about:preferences.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17863 solutions 161642 answers

Hi brianroy86

On Linux, you can create this pref to get a prompt to choose an application:

  • network.protocol-handler.expose.<protocol> = false
Hi brianroy86 On Linux, you can create this pref to get a prompt to choose an application: *network.protocol-handler.expose.<protocol> = false
Was this helpful to you?
Quote
brianroy86 0 solutions 4 answers

Thanks for trying, but I didn't get a prompt after adding that and restarting Firefox

Thanks for trying, but I didn't get a prompt after adding that and restarting Firefox
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17863 solutions 161642 answers

Chosen Solution

If you aren't prompted then this would suggest that the link doesn't use this specific protocol because only a protocol link will trigger such a request to choose the application.

If you aren't prompted then this would suggest that the link doesn't use this specific protocol because only a protocol link will trigger such a request to choose the application.
Was this helpful to you?
Quote

Question owner

My issue is now resolved with the update to Firefox 74.0. Must have been a bug!

My issue is now resolved with the update to Firefox 74.0. Must have been a bug!
Was this helpful to you? 0
Quote
brianroy86 0 solutions 4 answers

I'm on 74 as well, still having the issue.

I'm on 74 as well, still having the issue.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.