Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Arrange bookmarks manually

  • 10 replies
  • 1 has this problem
  • 13 views
  • Last reply by jayjoyce2

more options

My bookmarks will not arrange manually even though I have followed the below instructions from the help guide to the letter. Everytime I drag and drop it somewhere in the folder, 10 seconds later, it moves itself back.

Rearranging manually

   Click the Library button 57 library icon on your toolbar. (If you don't see it there, click the menu button fx57menu then click Library.) Click Bookmarks and then click the Show All Bookmarks bar at the bottom.
   Click the folder that contains the bookmark you want to move to expand it.
   Click on the bookmark you want to move and then drag it to the position where you want to move it.

Chosen solution

I followed your instructions and after restarting, it was still doing the same thing. So I tried a different test. I created another Folder and went to sites in the folder i had trouble with and then dragged them from the url window into the new folder. After pulling 3 in, I rearranged them and they stayed where I put them this time. Something about the original folder must have gotten corrupted. The new one lets me put them where I want to. So thank you all for your help. I guess it is solved at the moment.

Read this answer in context 👍 0

All Replies (10)

more options

Are you using Sync?

more options

The-edmeister,

Technically, I guess I am but only as of today. I created a Firefox account just to get access to help on this issue. But this was happening to me prior to creating the account. And I have no other devices linked to this account to sync with. I tried to turn it off just to clarify things but I couldn't figure out how to do that.

This issue happens whether I go into show all bookmarks or if I just drag and drop from the favorites toolbar inside a folder.

Thanks for the help,

more options

Try to disconnect Sync to see if that has effect.

more options

cor-el,

I have turned sync off and closed and then restarted firefox. The issue is still happening whether I drag and drop a link from the favorites toolbar folder in a browser session or if I go to show all bookmarks and drag and drop in a folder listed there. After about 7 seconds it always reverts back to it's original position. Also, just to be clear, I have set the sort option to "unsorted" (within the view drop down in the show all bookmarks screen).

I used to be able to rearrange them with ease. Not sure what is happening now but thank you for the help.

more options

You aren't dragging links from a so called smart folder list like recently bookmarked ?

Smart folder show the result of a database query in a list and aren't real existing folders. If you move a bookmark from this list then it will still appear in this list in the same location.

more options

No it is not a smart list. I created the folder and populated it by dragging website links down into the folder originally. I recently dropped two other websites into the folder and wanted them to be at the top of the folder list. That is why I am here as they will not stay at the top once I move them there.

more options

I think that only using Sync or problems with places.sqlite could be causing issues like you describe.

more options

SYNC is definitely off. But I am not familiar with places.sqlite or it's affect on Firefox.

more options

Open Help > Troubleshooting Information and scroll down to Places Database (the places.sqlite file) and use the Verify Integrity button.

Then wait for the verification process to run to completion and the chart of the process appears. See what may have been fixed.

Then restart Firefox and see if that issue has been corrected.

more options

Chosen Solution

I followed your instructions and after restarting, it was still doing the same thing. So I tried a different test. I created another Folder and went to sites in the folder i had trouble with and then dragged them from the url window into the new folder. After pulling 3 in, I rearranged them and they stayed where I put them this time. Something about the original folder must have gotten corrupted. The new one lets me put them where I want to. So thank you all for your help. I guess it is solved at the moment.