X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

How can I get Firefox to recognize YouTube?

Posted

When I try to play anything on YouTube I get the Firefox doesn't recognizemessage

When I try to play anything on YouTube I get the Firefox doesn't recognizemessage
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:72.0) Gecko/20100101 Firefox/72.0

More Information

jscher2000
  • Top 10 Contributor
8950 solutions 73359 answers

Hi circemae1, the player might be saying that it doesn't have any formats that Firefox knows how to play. I think that is very unusual on MacOS X systems.

Did this problem just start recently?

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • (menu bar) Help menu > Restart with Add-ons Disabled
  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi circemae1, the player might be saying that it doesn't have any formats that Firefox knows how to play. I think that is very unusual on MacOS X systems. Did this problem just start recently? Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * (menu bar) Help menu > Restart with Add-ons Disabled * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17846 solutions 161524 answers

Any specific media related messages in the Web Console ?

  • "3-bar" menu button or Tools -> Web Developer
Any specific media related messages in the Web Console ? *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Web_Console
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.