X
Tap here to go to the mobile version of the site.

Support Forum

Firefox has recently started coming up by itself when I boot my computer. Why? How do I stop it? thanks

Posted

I have checked my startup options and this is not one. Firefox does not start "immediately"; sometimes when I have started a Firefox session quickly after booting up, a second iteration appears (on top of the one in which I am working grrrr). I believe this is related to the last Windows update. It is VERY annoying and usually counter-productive. HELP!

I have checked my startup options and this is not one. Firefox does not start "immediately"; sometimes when I have started a Firefox session quickly after booting up, a second iteration appears (on top of the one in which I am working grrrr). I believe this is related to the last Windows update. It is VERY annoying and usually counter-productive. HELP!

Chosen solution

I thank you all for your suggestions; none of them turned up anything. However, Microsoft ran an update (in the background, unannounced) and since then this has stopped.  ?? 8-@ sigh. Ain't Windows grand?!?

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0  ?? I don't think so ... AdBlock Plus, DuckDuck Go, Roboform, Easy YouTube Video Downloader Express, YouTube MP4 Downloader

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

More Information

crankygoat
  • Top 25 Contributor
40 solutions 471 answers

You can use this tool: https://docs.microsoft.com/en-us/sysinternals/downloads/autoruns

Have a look at the page to familiarize yourself. It should also come with a help file.

It has a lot of tabs to separate categories, but the Logon tab should cover it for you. Otherwise, you can just use the Everything tab.

You are looking for: HKLM [...] Run (or variations on Run) HKCU [...] Run (or variations on Run) and Scheduled Tasks which are set to start Firefox. If you find any entries, you can just un-tick the box next to it to disable the autostart. It can be re-enabled any time you like.

Note that if you shut down Windows with applications (like Firefox) open, sometimes Windows thinks it is a good thing to restart them at login.

You can use this tool: https://docs.microsoft.com/en-us/sysinternals/downloads/autoruns Have a look at the page to familiarize yourself. It should also come with a help file. It has a lot of tabs to separate categories, but the Logon tab should cover it for you. Otherwise, you can just use the Everything tab. You are looking for: HKLM [...] Run (or variations on Run) HKCU [...] Run (or variations on Run) and Scheduled Tasks which are set to start Firefox. If you find any entries, you can just un-tick the box next to it to disable the autostart. It can be re-enabled any time you like. Note that if you shut down Windows with applications (like Firefox) open, sometimes Windows thinks it is a good thing to restart them at login.
Was this helpful to you? 0
Quote
FredMcD
  • Top 10 Contributor
4347 solutions 61140 answers
[https://support.mozilla.org/en-US/kb/firefox-starts-automatically-when-i-restart-window Firefox starts automatically when I restart Windows] {web link}
Was this helpful to you? 0
Quote

Question owner

This does not happen during a restart. Firefox starts up (by itself) only during a first boot. Neither Mozilla nor Firefox appears among the enabled startup items under the task manager.

This does not happen during a restart. Firefox starts up (by itself) only during a first boot. Neither Mozilla nor Firefox appears among the enabled startup items under the task manager.
Was this helpful to you?
Quote

Question owner

This did not solve the problem. This morning while I viewed the responses to this problem, it did it again. I believe that another process is causing this and was beginning to suspect a Microsoft game which I used for a few days and then deleted, however my husband tells me that he is having the same problem with his Google Chrome browser.

This did not solve the problem. This morning while I viewed the responses to this problem, it did it again. I believe that another process is causing this and was beginning to suspect a Microsoft game which I used for a few days and then deleted, however my husband tells me that he is having the same problem with his Google Chrome browser.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4347 solutions 61140 answers

When the browser starts, what is shown?

When the browser starts, what is shown?
Was this helpful to you?
Quote

Question owner

A blank page (my usual).

A blank page (my usual).
Was this helpful to you?
Quote
Wesley Branton
  • Top 10 Contributor
712 solutions 5608 answers

Did you check to see if the toolkit.winRegisterApplicationRestart preference is set to false, as suggested by FredMcD?

Did you check to see if the <code>toolkit.winRegisterApplicationRestart</code> preference is set to <code>false</code>, as suggested by FredMcD?
Was this helpful to you? 0
Quote

Question owner

No, I did not as this is not a case of Firefox coming up because it was left up when I shut down.

No, I did not as this is not a case of Firefox coming up because it was left up when I shut down.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17781 solutions 160842 answers

Does this also happen if you set another browser as the default browser in case Firefox currently is the default browser ?

Does this also happen if you set another browser as the default browser in case Firefox currently is the default browser ?
Was this helpful to you?
Quote
Wesley Branton
  • Top 10 Contributor
712 solutions 5608 answers

You should check to make sure that the toolkit.winRegisterApplicationRestart preference is set to false. Disabling that feature may fix the problem if maybe Firefox or Windows is incorrectly detecting that Firefox was left open.

You should check to make sure that the <code>toolkit.winRegisterApplicationRestart</code> preference is set to <code>false</code>. Disabling that feature may fix the problem if maybe Firefox or Windows is incorrectly detecting that Firefox was left open.
Was this helpful to you? 0
Quote

Chosen Solution

I thank you all for your suggestions; none of them turned up anything. However, Microsoft ran an update (in the background, unannounced) and since then this has stopped.  ?? 8-@ sigh. Ain't Windows grand?!?

I thank you all for your suggestions; none of them turned up anything. However, Microsoft ran an update (in the background, unannounced) and since then this has stopped. ?? 8-@ sigh. Ain't Windows grand?!?
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4347 solutions 61140 answers

Good to hear.

Good to hear.
Was this helpful to you?
Quote
crankygoat
  • Top 25 Contributor
40 solutions 471 answers

Ha! I am glad it was fixed for you, then. Sneaky Windows. :D

Ha! I am glad it was fixed for you, then. Sneaky Windows. :D
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.