Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Developer Edition (version 73.0b2, 64-bit) - Autoplay persists despite turning it off via options...

  • 3 replies
  • 1 has this problem
  • 64 views
  • Last reply by TyDraniu

more options

So I was looking at a Facebook group this morning and saw something that was posted in the group's feed that decided to autoplay on it's own despite "Block Audio and Video" being the default within the "Settings - Autoplay" screen.

I don't understand why this is constantly an issue with Firefox. Every single time, every update, every install, it always and continually becomes an issue with websites that I visit with Firefox. Even a completely fresh install with that above-mentioned setting, it's still an issue--nothing to do with customization of any kind, it's just that Firefox isn't doing what it's supposed to do.

What's going on here with this? Why isn't Firefox able to stop autoplay of videos within Facebook? I shouldn't have to rely on website settings to turn something like that off when it's the browser that allows the playback. I'm clearly missing something (I guess) so I'd appreciate if someone can shine some light on this because it's infuriating.

Chosen solution

All Replies (3)

more options

Chosen Solution

more options

Thanks, TyDraniu. That second link appears to have fixed the problem.

Do you have any idea why this keeps being problematic, though? It seems like with every version of Firefox, whether it's the developer version or otherwise, users have to keep revisiting this only to find new approaches to keep re-disabling autoplay. Do the developers keep overriding settings or something?

more options

Yea, this option was under heavy development recently. They've rethought how it should work once or twice.

Modified by TyDraniu