X
Tap here to go to the mobile version of the site.

Support Forum

<enter> key not using URL bar auto-suggestion

ben
Posted

When I type a few characters into the url bar, I see a list of completions from sites I've visited before, and the completion from the top match is highlighted in the URL bar. For example, if I type 'ny' into the search bar, I see a list of sites pop up with 'ny' in the url, and the URL bar itself now contains the original 'ny' characters followed by a highlighted string of 'times.com' since that's the site with nt in it that I've visited the most. So far, so good. The problem comes when I press <enter> however. Instead of taking me to the New York Times website as I intended, the browser reacts as if I only typed in ny in the search bar and hit <enter>, and it ignores the auto-suggestions that it just displayed. (In this case, it takes me to ny.com, which is not what I want). How do I get <enter> key presses to go to the completed url? Here is a screen cast showing exactly what I'm talking about: https://drive.google.com/file/d/1L4a_lLG0QRPRU6aKSvoUIa8MOvRwBCHm/view?usp=sharing

When I type a few characters into the url bar, I see a list of completions from sites I've visited before, and the completion from the top match is highlighted in the URL bar. For example, if I type 'ny' into the search bar, I see a list of sites pop up with 'ny' in the url, and the URL bar itself now contains the original 'ny' characters followed by a highlighted string of 'times.com' since that's the site with nt in it that I've visited the most. So far, so good. The problem comes when I press <enter> however. Instead of taking me to the New York Times website as I intended, the browser reacts as if I only typed in ny in the search bar and hit <enter>, and it ignores the auto-suggestions that it just displayed. (In this case, it takes me to ny.com, which is not what I want). How do I get <enter> key presses to go to the completed url? Here is a screen cast showing exactly what I'm talking about: https://drive.google.com/file/d/1L4a_lLG0QRPRU6aKSvoUIa8MOvRwBCHm/view?usp=sharing

Chosen solution

Actually, what Firefox is doing matches what happens when you hold down the Ctrl key and press Enter -- at least on Windows. So perhaps Firefox is a bit confused about the state of your Ctrl key. If you haven't restarted your system since this problem began, you might try that at some point and see whether Firefox can detect the Ctrl key (or lack thereof) normally after a reboot.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

Question owner

One more thing to add. Even if I press the right arrow key to go to the end of the highlighted string and hit enter, it still only considers the keys I actually typed. This is doubly confusing because pressing the right arrow removes the highlight from the completion string, so it _looks_ like I typed the whole string. You can see that in the second example from the video linked above.

One more thing to add. Even if I press the right arrow key to go to the end of the highlighted string and hit enter, it still only considers the keys I actually typed. This is doubly confusing because pressing the right arrow removes the highlight from the completion string, so it _looks_ like I typed the whole string. You can see that in the second example from the video linked above.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

That's very odd because the top line of the drop-down clearly shows Firefox intends to navigate to nytimes.com.

Any chance one of your extensions could be the culprit? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that seems related to outbound connections, address bar, search, or the "omnibox"? Anything you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

That's very odd because the top line of the drop-down clearly shows Firefox intends to navigate to nytimes.com. Any chance one of your extensions could be the culprit? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that seems related to outbound connections, address bar, search, or the "omnibox"? Anything you just do not remember installing or why? If in doubt, disable (or remove). Any improvement?
Was this helpful to you?
Quote

Question owner

Thanks for the suggestions, but it didn't help. I forgot to mention in my original post that I had tried starting the browser in "Safe Mode" to see if that would help, and I believe that mode disables all extensions. "Safe Mode" didn't seem to make any difference.

After reading those suggestions, I tried manually disabling. my extensions from the about:addons page. I disabled all except for "Firefox Multiaccount Containers" and restarted firefox, but that didn't help either.

Everything I've tried so far has had the same behavior: the url bar is populated with a highlighted completion after I type a few characters, but the browser only considers the few characters I've typed in when I press <enter>.

p.s. Another, possibly related issue is that pressing <enter> in a form text box (like the one I'm typing in now) seems to trigger a form submit instead of inserting a newline. I actually copied and pasted a newline from above in order to get paragraphs in this post. I don't know if this is related to the urlbar issue or not, but it seems like an extra data point.

Thanks for the suggestions, but it didn't help. I forgot to mention in my original post that I had tried starting the browser in "Safe Mode" to see if that would help, and I believe that mode disables all extensions. "Safe Mode" didn't seem to make any difference. After reading those suggestions, I tried manually disabling. my extensions from the about:addons page. I disabled all except for "Firefox Multiaccount Containers" and restarted firefox, but that didn't help either. Everything I've tried so far has had the same behavior: the url bar is populated with a highlighted completion after I type a few characters, but the browser only considers the few characters I've typed in when I press <enter>. p.s. Another, possibly related issue is that pressing <enter> in a form text box (like the one I'm typing in now) seems to trigger a form submit instead of inserting a newline. I actually copied and pasted a newline from above in order to get paragraphs in this post. I don't know if this is related to the urlbar issue or not, but it seems like an extra data point.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

After you type ny, is there any difference if you click the right-arrow button at the end of the address bar instead of pressing Enter?


Is address bar searching still enabled? That shouldn't be needed, but just in case there is some odd new interaction:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste keyw and pause while the list is filtered

(3) If the keyword.enabled preference is bolded and set to false, double-click it to restore the default value of true

After you type <code>ny</code>, is there any difference if you click the right-arrow button at the end of the address bar instead of pressing Enter? ---- Is address bar searching still enabled? That shouldn't be needed, but just in case there is some odd new interaction: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''keyw''' and pause while the list is filtered (3) If the '''keyword.enabled''' preference is bolded and set to false, double-click it to restore the default value of true
Was this helpful to you?
Quote

Question owner

Address bar searching is still enabled. The keyword.enabled preference was set to 'true'.

If I type 'ny' into the url bar and click the right arrow that shows up at the end of the bar, I _am_ taken to the New York Times website as I expect. So it seems like just hitting <enter> does not follow the auto-suggestion, but the right arrow does.

Address bar searching is still enabled. The keyword.enabled preference was set to 'true'. If I type 'ny' into the url bar and click the right arrow that shows up at the end of the bar, I _am_ taken to the New York Times website as I expect. So it seems like just hitting <enter> does not follow the auto-suggestion, but the right arrow does.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Okay, this is very puzzling because you would expect submitting ny to:

  • Go to the site listed next to Visit (autofill suggestion)
  • As a fallback, send what you typed to your search site (keyword service)
  • If the keyword service is disabled, try a fixup using www. before and .com after what you typed

So somehow both the first normal and first fallback behavior are getting skipped only for the Enter key.

What is special about the Enter key in your Firefox address bar?!

Did this problem just start with the latest update?

Okay, this is very puzzling because you would expect submitting ny to: * Go to the site listed next to Visit (autofill suggestion) * As a fallback, send what you typed to your search site (keyword service) * If the keyword service is disabled, try a fixup using www. before and .com after what you typed So somehow both the first normal and first fallback behavior are getting skipped only for the Enter key. What is special about the Enter key in your Firefox address bar?! Did this problem just start with the latest update?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Chosen Solution

Actually, what Firefox is doing matches what happens when you hold down the Ctrl key and press Enter -- at least on Windows. So perhaps Firefox is a bit confused about the state of your Ctrl key. If you haven't restarted your system since this problem began, you might try that at some point and see whether Firefox can detect the Ctrl key (or lack thereof) normally after a reboot.

Actually, what Firefox is doing matches what happens when you hold down the Ctrl key and press Enter -- at least on Windows. So perhaps Firefox is a bit confused about the state of your Ctrl key. If you haven't restarted your system since this problem began, you might try that at some point and see whether Firefox can detect the Ctrl key (or lack thereof) normally after a reboot.
Was this helpful to you? 1
Quote

Question owner

Ok then, I think I know what's wrong. I indeed do have a unique setup on my <enter> key. I've remapped it so that it registers as a normal <enter> when it's pressed, but as a <ctrl> when it's held down for longer than 500ms using xcape and xmodmap (this makes using my text editor of choice, Emacs, a lot easier on my wrists).

I haven't run into issues with any other apps, but I've tried to use Firefox off and on for the past few years, but this has always been an issue, and now I know why. Firefox seems to recognize the <enter> keypress as <ctrl> + <enter> because of my remapping. It could be that all the other apps I use treat <enter> and <ctrl> + <enter> the same, and this is the reason that I'm first running into it. The solution here might just be to bump up the timeout from 500ms to a second or more.

But, if that doesn't solve it, is there a way to remap those keybindings so that <ctrl> + <enter> behaves just like normal <enter> does?

In any case, thanks a lot for the clues. It really helped me figure out the issue.

Ok then, I think I know what's wrong. I indeed do have a unique setup on my <enter> key. I've remapped it so that it registers as a normal <enter> when it's pressed, but as a <ctrl> when it's held down for longer than 500ms using [https://github.com/alols/xcape xcape] and [https://www.x.org/archive/X11R6.8.1/doc/xmodmap.1.html xmodmap] (this makes using my text editor of choice, Emacs, a lot easier on my wrists). I haven't run into issues with any other apps, but I've tried to use Firefox off and on for the past few years, but this has always been an issue, and now I know why. Firefox seems to recognize the <enter> keypress as <ctrl> + <enter> because of my remapping. It could be that all the other apps I use treat <enter> and <ctrl> + <enter> the same, and this is the reason that I'm first running into it. The solution here might just be to bump up the timeout from 500ms to a second or more. But, if that doesn't solve it, is there a way to remap those keybindings so that <ctrl> + <enter> behaves just like normal <enter> does? In any case, thanks a lot for the clues. It really helped me figure out the issue.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Helpful Reply

ben said

But, if that doesn't solve it, is there a way to remap those keybindings so that <ctrl> + <enter> behaves just like normal <enter> does?

It took me a while to find this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste CTRL and pause while the list is filtered

(3) Double-click the browser.urlbar.ctrlCanonizesURLs preference to switch the value from true to false

Hopefully that will do it.

''ben [[#answer-1273808|said]]'' <blockquote> But, if that doesn't solve it, is there a way to remap those keybindings so that <ctrl> + <enter> behaves just like normal <enter> does? </blockquote> It took me a while to find this setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''CTRL''' and pause while the list is filtered (3) Double-click the '''browser.urlbar.ctrlCanonizesURLs''' preference to switch the value from true to false Hopefully that will do it.
Was this helpful to you? 1
Quote

Question owner

That worked! Thanks so much for your help!

That worked! Thanks so much for your help!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.