Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

How to stop URL bar from enlarging on click?

  • 40 replies
  • 15 have this problem
  • 15065 views
  • Last reply by jscher2000

more options

I am used to double clicking to select words in the URL bar. Not too long ago Firefox had an update where if you click on the URL bar then it would enlarge a bit. When it enlarges, so does the font, meaning that if I try to double click a word, the font resizing could shift the text. It is something minor, but something I am so used to doing. I was wondering if I could go back to the old URL bar that only got a blue highlight on click.

Chosen solution

**UPDATE**

The original solution was for Firefox 75. Due to changes in Firefox 77, the original solution is obsolete and there are new options.

Firefox supports an optional style sheet file named userChrome.css that we can use to modify the toolbar area, including taming the expanding address bar. Setting up your first userChrome.css file is about a 10 minute project, so when you have time to dive in, here are some threads to check out:

More background on userChrome.css files: https://www.userchrome.org/


Original Solution (Firefox 75-76)

In Nightly, there is a specific preference for this in about:config called browser.urlbar.update1 (previously known as browser.urlbar.megabar).

Setting that to false will revert the bar to its more typical behavior in new windows (the windows that are already open seem to keep the megabar behavior until the next session).

For anyone unfamiliar:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.update1 preference to switch the value from true to false

Note: This preference does not exist in Firefox 71-72.

Read this answer in context 👍 10

All Replies (20)

more options

Type about:config in address bar and Enter. Search " browser.urlbar.suggest.openpage " in search bar. Then set browser.urlbar.suggest.openpage to false. This will also fix the overlapping issue that some might be having with hidden urlbars.

more options

Hi Senali,

unfortunately this does not solve my problem. My problem is not the search suggestions, or what is typed or suggested in the URL bar, my problem is that the URL bar becomes a little bit bigger when you click on it, and when you click away it goes to normal size again. I want it to stay the same size at all times. See the attached images.

more options

Chosen Solution

**UPDATE**

The original solution was for Firefox 75. Due to changes in Firefox 77, the original solution is obsolete and there are new options.

Firefox supports an optional style sheet file named userChrome.css that we can use to modify the toolbar area, including taming the expanding address bar. Setting up your first userChrome.css file is about a 10 minute project, so when you have time to dive in, here are some threads to check out:

More background on userChrome.css files: https://www.userchrome.org/


Original Solution (Firefox 75-76)

In Nightly, there is a specific preference for this in about:config called browser.urlbar.update1 (previously known as browser.urlbar.megabar).

Setting that to false will revert the bar to its more typical behavior in new windows (the windows that are already open seem to keep the megabar behavior until the next session).

For anyone unfamiliar:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.update1 preference to switch the value from true to false

Note: This preference does not exist in Firefox 71-72.

Modified by jscher2000

more options

Thank you jscher2000, that is exactly what I was looking for!

more options

It's important to call out this bit:

> the windows that are already open seem to keep the megabar behavior until the next session

At first, i thought switching the parameter browser.urlbar.update1 didn't fix it, but closing the browser (thus closing the active window), and reopening it allows the url bar to go back to it's less distracting, non-enlarging behavior.

I can see how this will be useful to some; however, I'm quite pleased that it comes with an off switch for those whose minimalism finds it an awkward change in routine.

more options

This unnecessary change to the address bar behaviour is a a nuisance because it obscures my bookmarks toolbar with the enlarged 'megabar' and its drop shadow. I'm glad I could find a hidden preference in this thread to disable it but I wish I didn't have to go through the extra effort.

EDIT: spelling.

Modified by desjardins63

more options

Note that browser.urlbar.update1 will only work temporarily during the development stages of this feature as this pref is already gone in the current Nightly 77.0a1 builds. There is also a bug to remove browser.urlbar.openViewOnFocus, so in a few months a workaround via prefs is no longer possible.

An alternative is to use code in userChrome.css to revert the change in width and height of the location bar.

more options

cor-el said

Note that browser.urlbar.update1 will only work temporarily during the development stages of this feature as this pref is already gone in the current Nightly 77.0a1 builds. There is also a bug to remove browser.urlbar.openViewOnFocus, so in a few months a workaround via prefs is no longer possible. An alternative is to use code in userChrome.css to revert the change in width and height of the location bar.

How does a user register their displeasure with unwanted new features?

more options

You can leave feedback and comments via "Help -> Submit Feedback"

more options

Cheers. Thanks for your attention. Stay healthy.

more options

desjardins63 said

This unnecessary change to the address bar behaviour is a a nuisance because it obscures my bookmarks toolbar with the enlarged 'megabar' and its drop shadow. I'm glad I could find a hidden preference in this thread to disable it but I wish I didn't have to go through the extra effort.

I totally agree, same issue with obscuring bookmarks and it draws completely unnecessary focus to the search bar. I can't even imagine what the use case for this is other than some dev being bored with fixing functional bugs - like bookmark favicons not refreshing, if we're talking visual stuff...

more options

Yeah, same here... it obscures my bookmark toolbar. Delaying the whole point of having a quick access bookmark toolbar. Very distracting and just plain gets in the way. This is [one of the] worst features introduced in a while.

edit: still love you folks! :)

Modified by EMR

more options

I submitted my feedback on this via the Help menu as described above. I suggest anyone who feels the same leaves a polite note as well.

more options

"Kind of" worked, had to turn off all historical searching from the browser as well. I just added a separate search field to the right of it.

more options

EMR said

"Kind of" worked, had to turn off all historical searching from the browser as well. I just added a separate search field to the right of it.

I'm not sure what you tried. If you toggle the "update1" preference from true to false, the bar should change from the Firefox 75 behavior/appearance to the Firefox 74 behavior/appearance. That didn't work? Or it didn't get you all the way to what you wanted? If the solution needs to be updated, please explain the problem it didn't address so I can add that (since lots of people seem to be finding this thread).

more options

Updated browser.urlbar.update1 to false, included setting to false browser.urlbar.update1.* sub properties (just in case).

Open a new tab, or click on the url bar, it still pops up the history list. CTRL-L does the same thing. IDK, let me know if I can help, but at least now the URL bar isn't growing out of its space (couple steps forward?)

more options

EMR said

Updated browser.urlbar.update1 to false, included setting to false browser.urlbar.update1.* sub properties (just in case). Open a new tab, or click on the url bar, it still pops up the history list. CTRL-L does the same thing. IDK, let me know if I can help, but at least now the URL bar isn't growing out of its space (couple steps forward?)

Yes, the automatic opening has a different preference carried over from earlier versions. What the update1 change should have done was switch the list from "Top Sites" back to "Show History" but the list still opens when you click the address bar (or on a new tab). Unless you do this as well:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.openViewOnFocus preference to switch the value from true to false

more options

Perfect!!! Back to normal! Thanks a lot. I have 74 on my linux box for coding, and my Mac got updated to 75 (which I use for work-from-home presentation stuff) totally impeded everything and caught me off guard.

Thanks again!!!

more options

Note that the update1 and update2 prefs will be gone in a few releases (likely 77), so you will then have to use userChrome.css to revert styling features.

more options

This is horrible... it's the reason I don't use LibreOffice. They have thumbnails of previously opened documents with NO WAY of hiding them. This is not just a security issue with shouldersurfers, who ever thought this was a good idea?

Last thing I need when clicking on the URL bar is a random drop down telling CLIENT-A that I've been to CLIENT-B's site. Bad Idea! Please don't implement this, or at least have a way to "unclick" to turn this off instead of editing a CSS.

  1. 1
  2. 2