X
Tap here to go to the mobile version of the site.

Support Forum

Userchrome search bar broken again in Firefox v70

Posted

Problem:

Back in 2015, Mozilla destroyed the search bar by removing the text labels, making it almost impossible to search because you can't find the engine you want. They also removed the ability to switch engines, meaning you have to nominate your engine every single time you search.

On top of this, Mozilla reversed the order you do things: It used to be that first you chose the type of content you wanted, then you thought about your exact query. But now, you first have to specify your exact query and THEN think about the type of content you want to search for, which is totally counter-intuitive and terrible interface design. It's like being asked for the name of the meal, movie or book you want, before you've even decided whether you want a meal, movie or book!

The reason Mozilla gave for these awful changes was to "make searching faster", but that simply is not the case. The new search bar requires just as many clicks, yet it's drastically slower to use as it's almost impossible to find the engine you're looking for from all the unlabeled engines. Plus, having to type your query first is completely counterintuitive to the user's thought process and slows things down even further.

Solution:

For a couple of years, Classic Theme Restorer was the perfect solution, bringing back the old bar exactly as it should be. However, since Firefox Quantum, Classic Theme Restorer doesn't work, so I've been using Jefferson Scher's excellent userchrome script. (Thank you Mr Scher!)

Sadly, with Firefox 70, the script seems to be broken again and many of the engines are missing from the list. I've tried taking the script directly from Jefferson Scher's website, but doing so just makes text labels disappear. It just seems to be broken again.

Problem: Back in 2015, Mozilla destroyed the search bar by removing the text labels, making it almost impossible to search because you can't find the engine you want. They also removed the ability to switch engines, meaning you have to nominate your engine every single time you search. On top of this, Mozilla reversed the order you do things: It used to be that first you chose the type of content you wanted, then you thought about your exact query. But now, you first have to specify your exact query and THEN think about the type of content you want to search for, which is totally counter-intuitive and terrible interface design. It's like being asked for the name of the meal, movie or book you want, before you've even decided whether you want a meal, movie or book! The reason Mozilla gave for these awful changes was to "make searching faster", but that simply is not the case. The new search bar requires just as many clicks, yet it's drastically slower to use as it's almost impossible to find the engine you're looking for from all the unlabeled engines. Plus, having to type your query first is completely counterintuitive to the user's thought process and slows things down even further. Solution: For a couple of years, Classic Theme Restorer was the perfect solution, bringing back the old bar exactly as it should be. However, since Firefox Quantum, Classic Theme Restorer doesn't work, so I've been using Jefferson Scher's excellent userchrome script. (Thank you Mr Scher!) Sadly, with Firefox 70, the script seems to be broken again and many of the engines are missing from the list. I've tried taking the script directly from Jefferson Scher's website, but doing so just makes text labels disappear. It just seems to be broken again.

Modified by MartyJames

Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

jscher2000
  • Top 10 Contributor
8799 solutions 71970 answers

Helpful Reply

MartyJames said

Sadly, with Firefox 70, the script seems to be broken again and many of the engines are missing from the list. I've tried taking the script directly from Jefferson Scher's website, but doing so just makes text labels disappear. It just seems to be broken again.

Are you saying that search engines go missing when styling the drop-down, or they are missing either way?

Styling Issue

I think I updated the rules for Firefox 70, since it is working for me currently. Which layout are you choosing?

(I just now hid the code for the icon in the search bar; due to a change a couple versions ago, that stopped working. You only need the code that opens in a separate tab.)

Missing Search Engines

Are the missing search engines are still visible to Firefox elsewhere?

Check whether the missing search engines are listed on the Search panel of the Options page, in the One-Click Search Engines box?

If not, try the "Restore Default Search Engines" button below the box.

If that doesn't bring them back, there could be a corrupted file problem. Unfortunately, the easy remedy will only restore the default set and remove the "traditional" ones you've added (traditional meaning XML format OpenSearch plugins; the ones added by currently installed extensions will be fine).

If needed:

Sometimes the settings file that stores window dimensions becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename search.json.mozlz4 to something like searchOLD.json.mozlz4. By renaming instead of deleting, you'll hopefully be able to extract its contents later for reference if needed.

Start Firefox back up again. It should rediscover the built-in search engines and allow you to check and modify the default, and which ones are visible on drop-downs.

Does that work?

''MartyJames [[#question-1273061|said]]'' <blockquote> Sadly, with Firefox 70, the script seems to be broken again and many of the engines are missing from the list. I've tried taking the script directly from Jefferson Scher's website, but doing so just makes text labels disappear. It just seems to be broken again. </blockquote> Are you saying that search engines go missing when styling the drop-down, or they are missing either way? '''''Styling Issue''''' I think I updated the rules for Firefox 70, since it is working for me currently. Which layout are you choosing? (I just now hid the code for the icon in the search bar; due to a change a couple versions ago, that stopped working. You only need the code that opens in a separate tab.) '''''Missing Search Engines''''' Are the missing search engines are still visible to Firefox elsewhere? Check whether the missing search engines are listed on the Search panel of the Options page, in the '''One-Click Search Engines''' box? If not, try the "Restore Default Search Engines" button below the box. If that doesn't bring them back, there could be a corrupted file problem. Unfortunately, the easy remedy will only restore the default set and remove the "traditional" ones you've added (traditional meaning XML format OpenSearch plugins; the ones added by currently installed extensions will be fine). ''If needed:'' Sometimes the settings file that stores window dimensions becomes corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, on the '''Profile Folder''' row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''search.json.mozlz4''' to something like searchOLD.json.mozlz4. By renaming instead of deleting, you'll hopefully be able to extract its contents later for reference if needed. Start Firefox back up again. It should rediscover the built-in search engines and allow you to check and modify the default, and which ones are visible on drop-downs. Does that work?
Was this helpful to you? 1
Quote

Question owner

Mr Scher, you are such a kind soul! I can't believe how tirelessly you work to help people with their problems, asking nothing in return. :) Bless you!

A bit more info, to answer your questions:

• All the search engines are present in the list in Firefox's options.

• When I remove the custom UserChrome script, all the engines appear correctly in the search box (as icons).

• With the UserChrome script enabled, there seems to be some kind of graphical glitch on my machine, with the various search engines appearing on top of one another (screenshot attached). This has been the case since I upgraded to Firefox 70.

• This problem still occurs when I disable all add-ons, and also when I test it in a different profile.

Mr Scher, you are such a kind soul! I can't believe how tirelessly you work to help people with their problems, asking nothing in return. :) Bless you! A bit more info, to answer your questions: • All the search engines are present in the list in Firefox's options. • When I remove the custom UserChrome script, all the engines appear correctly in the search box (as icons). • With the UserChrome script enabled, there seems to be some kind of graphical glitch on my machine, with the various search engines appearing on top of one another (screenshot attached). This has been the case since I upgraded to Firefox 70. • This problem still occurs when I disable all add-ons, and also when I test it in a different profile.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8799 solutions 71970 answers

Chosen Solution

Yes, the result is quite ugly there. Could you refresh your code with the latest update. Sorry I forgot to give the link before: https://www.jeffersonscher.com/gm/search-bar-names.html This link will give you the default settings for the 2-column layout in case you want to test: https://userstyles.org/styles/122214.css?ik-vertspace=ik-twocol&ik-searchfor=ik-hidesearchfor&ik-addengine=ik-showengine&ik-chgsettings=ik-showchg&ik-tooltiptext=ik-tttno&ik-colorscheme=ik-colorschemelight&ik-theming=ik-themenone&ik-usertextcolor=%23FFFFFF&ik-userbackcolor=%230000FF&ik-userboldness=ik-weightnormal
Was this helpful to you? 1
Quote

Question owner

OK, I went back to your site and took the code and this time it worked perfectly! No idea why it didn't work before.

Thank you once again sir! :)

OK, I went back to your site and took the code and this time it worked perfectly! No idea why it didn't work before. Thank you once again sir! :)
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.