X
Tap here to go to the mobile version of the site.

Support Forum

Firefox will not allow google to be home page

Posted

Hello -- Weird thing, here. I'm trying to help a friend of mine. Recently Firefox on his Windows 10 laptop will not open google as his home page. When he opens Firefox the status bar indicates it's attempting a TLS handshake with google but after many, many seconds a blank page appears. I have made sure it's set as his home page and have done a refresh on Firefox. What's weird (to me, anyway) is that I can set any other page as his home page and it will open up directly into that page. Not google.

I'm guessing an update broke it but am not there daily. Please let me know what other specifics are needed to help me solve this for him.

TIA.

Nick

Hello -- Weird thing, here. I'm trying to help a friend of mine. Recently Firefox on his Windows 10 laptop will not open google as his home page. When he opens Firefox the status bar indicates it's attempting a TLS handshake with google but after many, many seconds a blank page appears. I have made sure it's set as his home page and have done a refresh on Firefox. What's weird (to me, anyway) is that I can set any other page as his home page and it will open up directly into that page. Not google. I'm guessing an update broke it but am not there daily. Please let me know what other specifics are needed to help me solve this for him. TIA. Nick

Chosen solution

Hello, all -- Finally got over to the laptop in question.

A Malwarebytes scan identified and quarantined about 12 PUPs. No joy. Solving the problem required a uninstall/reinstall of Firefox which created a completely new user profile.

Thanks, all, for the assist.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

FredMcD
  • Top 10 Contributor
4269 solutions 59840 answers

How was the home page set up? What link are you using?


https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

How was the home page set up? What link are you using? https://support.mozilla.org/en-US/kb/how-to-set-the-home-page
Was this helpful to you?
Quote

Question owner

I clicked on Tools, Options, Home, typed in "google", selected "https://www.google.com" from the drop-down. Exited and restarted Firefox.

What I forgot to mention in my initial post is that once Firefox settles out on a blank tab, clicking on the Home button brings up google.

I saw in another forum something about Avast! being a potential issue with TLS handshake timeout. I know he's using Avast! so I'll try to remote in tomorrow and check that. Don't remember there being any non-standard extensions or plugins installed but will verify.

Thanks.

I clicked on Tools, Options, Home, typed in "google", selected "https://www.google.com" from the drop-down. Exited and restarted Firefox. What I forgot to mention in my initial post is that once Firefox settles out on a blank tab, clicking on the Home button brings up google. I saw in another forum something about Avast! being a potential issue with TLS handshake timeout. I know he's using Avast! so I'll try to remote in tomorrow and check that. Don't remember there being any non-standard extensions or plugins installed but will verify. Thanks.
Was this helpful to you?
Quote

Question owner

Sorry for the delayed update.

I was able to remote into the laptop earlier this evening and compared his settings with mine (I have no issues setting google as my home page). I found no differences in the settings of Firefox, Avast! and the PCs.

Also want to note this behavior started prior to this week's Windows update. He will try an uninstall/reinstall of Firefox as soon as he completes his current project.

At a total loss here; hoping someone can shed some light on this.

Sorry for the delayed update. I was able to remote into the laptop earlier this evening and compared his settings with mine (I have no issues setting google as my home page). I found no differences in the settings of Firefox, Avast! and the PCs. Also want to note this behavior started prior to this week's Windows update. He will try an uninstall/reinstall of Firefox as soon as he completes his current project. At a total loss here; hoping someone can shed some light on this.

Modified by nick.firefox1

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17570 solutions 158915 answers

Try to disable IPv6 (check for other possible causes as well).

Try to disable IPv6 (check for other possible causes as well). *https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can
Was this helpful to you?
Quote

Chosen Solution

Hello, all -- Finally got over to the laptop in question.

A Malwarebytes scan identified and quarantined about 12 PUPs. No joy. Solving the problem required a uninstall/reinstall of Firefox which created a completely new user profile.

Thanks, all, for the assist.

Hello, all -- Finally got over to the laptop in question. A Malwarebytes scan identified and quarantined about 12 PUPs. No joy. Solving the problem required a uninstall/reinstall of Firefox which created a completely new user profile. Thanks, all, for the assist.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4269 solutions 59840 answers

That was very good work. Well Done.

That was very good work. Well Done.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.