Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"The page isn’t redirecting properly" when try download file in google drive

  • 6 replies
  • 2 have this problem
  • 860 views
  • Last reply by kiriha86

more options

it show massage "The page isn’t redirecting properly" every I try download file from my google drive. I search solution in mozilla support and lot of them sugest to delete cookies cause cookies corrupt or like that. but still same not solved.

please help, thanks.

Attached screenshots

Chosen solution

I get the solution. thanks to Rotary Steve. first, I try download in Private Window and download process work well. then I try in normal mode are work as well. at least for now.

I hope it help, and not show problem again.

thank you for you all that response my problem.

Read this answer in context 👍 0

All Replies (6)

more options
more options

This issue can be caused by corrupted cookies or cookies that are blocked.

  • check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions"

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

still not working even I had does set permission cookies to "Allow" and run in safe mode. same case with reload web page + bypass the cache.

more options
more options

Maybe check the date and time.

You can check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

more options

Chosen Solution

I get the solution. thanks to Rotary Steve. first, I try download in Private Window and download process work well. then I try in normal mode are work as well. at least for now.

I hope it help, and not show problem again.

thank you for you all that response my problem.