X
Tap here to go to the mobile version of the site.

Support Forum

How do I disable TLS handshaking in Firefox 70.0?

Posted

Since upgrading to 70.0 each page takes ridiculously long to get through TLS handshaking (10 - 15 seconds not unusual). How do I disable it.

Since upgrading to 70.0 each page takes ridiculously long to get through TLS handshaking (10 - 15 seconds not unusual). How do I disable it.

Chosen solution

A TLS handshake isn't something that you can disable. It's an essential step in connecting to a website. It's the initial step that connects you to the website's server.

If you find that it's taking a long time, it could be your security software. Avast and AVG have caused this a lot in the past. There is an Enable HTTPS Scanning option somewhere in the Avast/AVG settings that you can disable to speed up the process.

Another common culprit are add-ons, specifically content blocking add-ons. You can try running Firefox in Safe Mode to see if the problem goes away. If it does, one of your add-ons that you have installed on Firefox is likely slowing down the TLS handshake process.

Hope this helps.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

Ghostery and several others

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

Wesley Branton
  • Top 25 Contributor
720 solutions 5654 answers

Chosen Solution

A TLS handshake isn't something that you can disable. It's an essential step in connecting to a website. It's the initial step that connects you to the website's server.

If you find that it's taking a long time, it could be your security software. Avast and AVG have caused this a lot in the past. There is an Enable HTTPS Scanning option somewhere in the Avast/AVG settings that you can disable to speed up the process.

Another common culprit are add-ons, specifically content blocking add-ons. You can try running Firefox in Safe Mode to see if the problem goes away. If it does, one of your add-ons that you have installed on Firefox is likely slowing down the TLS handshake process.

Hope this helps.

A TLS handshake isn't something that you ''can'' disable. It's an essential step in connecting to a website. It's the initial step that connects you to the website's server. If you find that it's taking a long time, it could be your security software. Avast and AVG have caused this a lot in the past. There is an '''Enable HTTPS Scanning''' option somewhere in the Avast/AVG settings that you can disable to speed up the process. Another common culprit are add-ons, specifically content blocking add-ons. You can [[Troubleshoot Firefox issues using Safe Mode|try running Firefox in Safe Mode]] to see if the problem goes away. If it does, one of your add-ons that you have installed on Firefox is likely slowing down the TLS handshake process. Hope this helps.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.