Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

upgraded to 70.0 and now there is a 6 second delay on loading first site

  • 29 replies
  • 7 have this problem
  • 258 views
  • Last reply by Piterk

more options

I have upgraded to 70.0 and now there is a 6 second delay on loading first site. I have firefox starting in private mode and without a home page. this loads at its usual speed. However, when I click on a bookmark the system hangs for 6 seconds before the site is presented. Subsequent sites load rapidly as usual. I have tested with other browsers and sites and the problem is specific to Firefox and not specific to the site being load. Once loaded, if I open an additional Firefox window this loads sites rapidly. I have been using Firefox for many years and the problem has only occurred since I upgraded to 70.0.

Can anyone help please.

Chosen solution

Hurrahh! I have just upgraded to V71.0 and the problem is fixed. Sites are now loaded instantly - there is no long-duration delay while F/F goes through its start-up process. Well done the developers.

Read this answer in context 👍 0

All Replies (20)

more options

Yes i have been using Firefox for years too, and never had a problem until I upgraded to 70.0. Hope they are able to get to the root of the problem.

more options

hello, can you replicate the problem in a new profile (that you can create for testing purposes when you type about:profiles into the address bar)? also, what security software are you suing - maybe we can find some similarities among affected users)

more options

Hi Philipp, Some interesting diagnostic information has emerged. I did as you suggested and created a new profile for testing. The results with the new profile were identical to that with the normal profile BUT during testing I discovered something. The delay is nothing to do with the first website - it seems to be part of the F/F initialization process. This is what happened: 1. Start F/F and immediately go to an external site (I used bbc.co.uk) - delay of 10 seconds before site is served. 2. Start F/F and do nothing for 10 seconds then go to bbc.co.uk - site is served immediately. 3. I have replicated this a number of times and the delay is with F/F initialization 4. I ran some tests with the Windows Task Manager window open but during the 10 second initialization F/F consumed very little CPU - e.g. approx. 1 - 2%

My security software is Bitdefender.

more options

thank you for following up and doing some testing.

could you try to capture and share a performance profile during startup: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem

perhaps it can give some clues what's going wrong. install the profiling addon, restart firefox once and immediately press Ctrl+Shift+1 once firefox has launched, then quickly try to load a website and press Ctrl+Shift+2 once the site has loaded. then please share the profile with us.

due to the nature of the problem at startup i'm not sure if this method is successful in capturing the root of the problem or if it's even possible to perform, but it's certainly worth a try...

more options

Thanks. I am having difficulty turning on performance logging - will forward something as soon as I can it set up. However, I was able to turn on http logging during the start-up phase and have captured the log files. They are zipped to 80k but the forum will not let me upload them - is there a way of getting them to you?

more options

you could upload it through https://send.firefox.com/ and send me a PM with the link. thnx

more options
more options

Is this also happening if you type a URL in the location/address bar?

It is possible that your security is blocking access to places.sqlite.

more options

Thanks cor-el but if you see the posts above you will see that the issue is confined to the F/F start-up process and is occurring before any site is requested. F/F is starting in private mode with no home site specified.

more options

There are no policies active in Firefox ?

You can check the about:policies#active page to see whether policies are active.

more options

about:policies#active gives the following:

The Enterprise Policies service is inactive.

more options
more options

Hi, similar problem but much more than 10 second delay - nearer 25. Have Reset FF, no change, started in safe mode, no change, disabled add ons etc, no change. One other common feature - I'm also using Bitdefender.

more options

Further to my last, I agree that it's an initial delay. I've jst started FF and waited for 30+ seconds then clicked on a tool bar bookmark and it loads with the expected speed. Hope that helps.

more options

Are you using the default Home Page? If so, on the about:preferences#home page which features of the Firefox Home Content are selected?

If you are using the Recommended by Pocket feature try disabling that Content and see if there is an improvement.

more options

Thanks for your response. The screenshot shows defaults for most things. I tried blank screen and custom url and both had the same delay of almost a half minute

However, please see attached FF.png - could this be causing the problem? I'm out of my depth here but it looks as if something's not right.

FWIW both laptops in the house are using FF70 and same OS (Win7 64 bit) and are behaving perfectly.

Thanks again.

more options

Hi the-edmeister, I can confirm that the issue is confined to the F/F start-up process and is occurring before any site is requested. I start F/F without any page specified and the delay is approx. 12 seconds.

more options

I have the same issue.

However, I think it's because of some new code upgrades on this version (checking updates, checking version info, checking about new extensions etc?). Better to check about this issue by next version.

more options

Hi , did you try clearing you cache and cookies ?? Most of the time clearing cookies helps. And if you can try clearing the browser history and temp (the steps are given below) files on your PC. Most of the time clearing temps help speed up the browser.


How to clean temporary (temps)

1.Open "RUN" 2. Type "%temp" and click run or press enter 3. Then delete the files there. <deleting <="" affect="" bad="" in="" p="" pc="" way.="" wont="" your=""></deleting>

Hope this fix the issue . Thank you.

more options

Thanks. Yes, all user storage is cleared at the end of every session. The problem occurs even with a fresh install of F/F.

  1. 1
  2. 2