X
Tap here to go to the mobile version of the site.

Support Forum

How do I get tabs on bottom in FireFox 69+? I had it working with the userChrome code up until the October 2019 update.

Posted

Mozilla STOP BREAKING YOUR OWN BROWSER! EVERY UPDATE!!! Nobody likes tabs on top. NOBODY. Stop forcing us to put tabs on top. This is so annoying. You wonder why your browser marketshare is rapidly dropping every year, it's because of like this.

[Profanity removed by moderator. Please read Forum rules and guidelines, thanks.]

Mozilla STOP BREAKING YOUR OWN BROWSER! EVERY <!-- ****ING -->UPDATE!!! Nobody likes tabs on top. NOBODY. Stop forcing us to put tabs on top<!-- , you fascist nerdy pieces of **** -->. This is so <!-- ****ing -->annoying. You wonder why your browser marketshare is rapidly dropping every year, it's because of <!-- bull**** -->like this. <!-- **** you. --> <!-- ORIGINAL SUBJECT: How do I get tabs on bottom in FireFox 69+? I had it working with the userChrome code up until the October 2019 update. WTF! --> ''[Profanity removed by moderator. Please read [[Forum rules and guidelines]], thanks.]''

Modified by Chris Ilias

Chosen solution

Adding this snippets should move the tabs under the URLbar like it was possible before Firefox Quantum:

--- #navigator-toolbox { display: flex; flex-direction: column; } #titlebar { order: 2; } ---

However, keep in mind the following:

"Support for the userChrome.css file and any of its elements described below are not guaranteed in future versions of Firefox. Using it may lead to hard-to-diagnose bugs or crashes. Use at your own risk!" -- https://developer.mozilla.org/en-US/docs/Archive/Mozilla/XUL/Tutorial/Modifying_the_Default_Skin

In other word, userChrome.css isn't supported officially.

Read this answer in context 1
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Seeing userChrome.css in the first screenshot might be an indication that there is a hidden .txt or .css file extension appended to the file name (userChrome.css.css or userChrome.css.txt) because otherwise you would see userChrome without a file extension like in the second screenshot. So you need to check the properties of the file or check the type in Windows File Explorer.

Seeing userChrome.css in the first screenshot might be an indication that there is a hidden .txt or .css file extension appended to the file name (userChrome.css.css or userChrome.css.txt) because otherwise you would see userChrome without a file extension like in the second screenshot. So you need to check the properties of the file or check the type in Windows File Explorer.
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

To make sure you see .css and .txt file extensions and can fully control file names on Windows:

https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

To make sure you see .css and .txt file extensions and can fully control file names on Windows: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/
ddelavie 0 solutions 10 answers

I already have the 'View all extensions for folders and files' activated. That is something I always do.

That is why you see the full name on the Screenshots. I see the full name in my folders.

I see all Hidden files and folders , extensions for known file types, and protected Operating system files.

Always.

I already have the 'View all extensions for folders and files' activated. That is something I always do. That is why you see the full name on the Screenshots. I see the full name in my folders. I see all Hidden files and folders , extensions for known file types, and protected Operating system files. Always.
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

ddelavie said

I already have the 'View all extensions for folders and files' activated. That is something I always do. That is why you see the full name on the Screenshots. I see the full name in my folders.

The thing that puzzled cor-el was the title bar of your Notepad screenshots:

  • userChrome.css
  • userChrome-tabs_on_bottom_Fx70 -- no file extension?

One possible explanation for that was the true file names were:

  • userChrome.css.css
  • userChrome-tabs_on_bottom_Fx70.css

The true file names need to be:

  • userChrome.css
  • userChrome-tabs_on_bottom_Fx70.css
''ddelavie [[#answer-1260643|said]]'' <blockquote> I already have the 'View all extensions for folders and files' activated. That is something I always do. That is why you see the full name on the Screenshots. I see the full name in my folders. </blockquote> The thing that puzzled cor-el was the title bar of your Notepad screenshots: * userChrome'''.css''' * userChrome-tabs_on_bottom_Fx70 -- no file extension? One possible explanation for that was the true file names were: * userChrome'''.css.css''' * userChrome-tabs_on_bottom_Fx70'''.css''' The true file names need to be: * userChrome'''.css''' * userChrome-tabs_on_bottom_Fx70'''.css'''
ddelavie 0 solutions 10 answers

Thanks for your help Jscher and cor-el!

Problem solved. I've reverted back to Firefox ver 68.0.1 and turned OFF automatic updates.

I'll stay there until I find other options.

Tabs should be directly above the content they hold.

What happened to just being able to toggle on 'tabs on bottom' in about:config ?

In any case, -- Thanks again.

Thanks for your help Jscher and cor-el! Problem solved. I've reverted back to Firefox ver 68.0.1 and turned '''OFF''' automatic updates. I'll stay there until I find other options. Tabs should be directly above the content they hold. What happened to just being able to toggle on 'tabs on bottom' in about:config ? In any case, -- Thanks again.
ddelavie 0 solutions 10 answers

BTW -- just to clear the confusion, . . .

I typed in the names of those screenshots when I was doing a 'save as', . .

I typed them in as I knew them to be, . . . .just forgot the .css on the one.

Sorry that muddied the issue, . . .

BTW -- just to clear the confusion, . . . I typed in the names of those screenshots when I was doing a 'save as', . . I typed them in as I knew them to be, . . . .just forgot the .css on the one. Sorry that muddied the issue, . . .
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

ddelavie said

BTW -- just to clear the confusion, . . . I typed in the names of those screenshots when I was doing a 'save as', . . I typed them in as I knew them to be, . . . .just forgot the .css on the one. Sorry that muddied the issue, . . .

We weren't looking at the file names of the screenshots -- the forum changes those anyway -- but the title bar of the Notepad window. They should be consistently showing either .css (if Windows shows all file extensions) or nothing (if Windows is hiding the .css file extension). The inconsistency suggested a file naming problem. Sorry that wasn't clear.

''ddelavie [[#answer-1260709|said]]'' <blockquote> BTW -- just to clear the confusion, . . . I typed in the names of those screenshots when I was doing a 'save as', . . I typed them in as I knew them to be, . . . .just forgot the .css on the one. Sorry that muddied the issue, . . . </blockquote> We weren't looking at the file names of the screenshots -- the forum changes those anyway -- but the title bar of the Notepad window. They should be consistently showing either .css (if Windows shows all file extensions) or nothing (if Windows is hiding the .css file extension). The inconsistency suggested a file naming problem. Sorry that wasn't clear.