Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The title bar is present when disabled (Linux)

  • 8 replies
  • 1 has this problem
  • 397 views
  • Last reply by ender21

more options

I noticed that the title bar is present and opened the 'customise' page. "Title bar" is unchecked. I have tried checking and unchecking it using this and other system themes and have also tried that from another system. In about:config the setting "browser.tabs.drawInTitlebar" is true. I have long had css code which places the tab bar below the location bar. Above the location bar I have the menu bar which, in addition to the classic menu, has toolbar buttons and the "bookmarks toolbar". Bookmarks Toolbar is not checked in the list. That has been my setup for years; the current profile is over a year old and previously had no title bar. Some months ago I showed the title bar to facilitate moving buttons on the menu bar then disabled it. I am attaching images.

I noticed that the title bar is present and opened the 'customise' page. "Title bar" is unchecked. I have tried checking and unchecking it using this and other system themes and have also tried that from another system. In about:config the setting "browser.tabs.drawInTitlebar" is true. I have long had css code which places the tab bar below the location bar. Above the location bar I have the menu bar which, in addition to the classic menu, has toolbar buttons and the "bookmarks toolbar". Bookmarks Toolbar is not checked in the list. That has been my setup for years; the current profile is over a year old and previously had no title bar. Some months ago I showed the title bar to facilitate moving buttons on the menu bar then disabled it. I am attaching images.
Attached screenshots

Chosen solution

On Linux hiding the title bar is done via CSD (client-side-decoration), so if it isn't working then there appears to be a problem with CSD.

  • bug 1283299 - (gtktitlebar) Implement titlebar rendering on GTK 3.20+

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Read this answer in context 👍 1

All Replies (8)

more options

Did you try yo disable userChrome.css in case you use this file to customize Firefox ?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Thanks for replying. Starting in "Safe Mode" started without the menu bar but the title bar was still present and not enabled in Customise.

Restarting with stylesheets disabled also still showed the title bar with no enabling in Customise.

Switching to the "Default theme" in the Add-ons Manager, only changed the background colour since that's all my theme does. There seems to be no way to change to the new menu style if I use this profile.

more options

Hi

Which desktop environment are you using?

more options

Hello. I am using KDE with GTK2 theme MurrinaChromium. GTK3 theme is Adwaita. I have tried changing both themes to Breeze (which is the KDE preference) on another KDE system, without any change in behaviour.

more options

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Thanks for replying. I anticipated that the issue was confined to one profile and hoped to find out what is causing it.

However, I started Firefox using another profile. The title bar was present but was enabled in Customise. After I disabled it, it did NOT disappear. I started with that profile again and the title bar was still present.

I created a third profile. It had the title bar also and it persisted after I disabled it in Customise and after I enabled the menu bar.

more options

Chosen Solution

On Linux hiding the title bar is done via CSD (client-side-decoration), so if it isn't working then there appears to be a problem with CSD.

  • bug 1283299 - (gtktitlebar) Implement titlebar rendering on GTK 3.20+

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

Thanks. I didn't search Bugzilla because I thought if it wasn't just me there would have been an outcry. I'll search first next time.

Having said that, I was previously able to make the title bar go away in this profile using Customise.

The only css code I have found so far doesn't work and perhaps that's because it's GTK which drives the setting in Linux.