Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 69.0.1 always displays startup message saying that Firefox is not my Win 10 default browser

  • 4 replies
  • 1 has this problem
  • 22 views
  • Last reply by FredMcD

more options

Despite having set Firefox as my Win 10 default browser and regardless of the Firefox Options setting (checkmark or no checkmark on "Always check if Firefox is your default browser"), I always get a message at Firefox startup saying Firefox is not set as my default browser. Clicking on the Firefox Options/General/Startup: "Make Default" button takes me to Windows Default Apps, where it shows me that Web Browser is already set to Firefox.

Its annoying.

What is the meaning of the note at the top of Options saying "Your browser is being managed by your organization"? Clicking on it just shows a list with no ability to change anything, nor do I see any reason to think that its related to my problem.

(I'm a long-time Firefox user)
Attached screenshots

All Replies (4)

more options

Hi car-nuts,

I think the cause of this may be your AV program. I found this article for similar issue to yours on FF 67 and (at the time) 69 Nightly on Windows 10 using Avast: techdows.com.

The solution provided in the article suggests the following:

  1. Enter about:policies into the URL bar and check that it shows an 'Active' status along with a Policy Value of ImportEnterpriseRoots as true
  2. Open Registry Editor and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Policies
  3. Delete the Mozilla directory inside Policies
  4. Restart Firefox
more options

Do you have more than one Firefox program installed?

• (64-bit Firefox) "C:\Program Files\Mozilla Firefox\" • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"

more options

Vjba: I tried your solution but it had no effect.

FredMcD: You are spot-on!!! ... yes, it seems I do have both 64-bit and 32-bit Firefox installed, and the 32-bit version is coming up... that surprised me. I tried running the 64-bit version and it came up without the message about setting Firefox as my default browser

So, I will change over to the 64-bit version.

Thanks!!!

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.