X
Tap here to go to the mobile version of the site.

Support Forum

Cannot turn off multi-threading.

Posted

I have read multiple responses to the ridiculous multi-threading "feature" in FF, tried all the suggested fixes, but none work. This one - The multi-process opt-in pref browser.tabs.remote.autostart.2 is no longer used in Firefox 58. In Firefox 58+ only browser.tabs.remote.autostart is used, so you need to set this pref to false to disable multi-process. also does not work - I have done this and gone back multiple times to check the setting, which hasn't changed from the False, but the multi-threading demon remains active. It is constantly crashing my system - not just the browser. And yes, I use the updated versions all the time. I really need to stop this feature once and for all, and if FF can't fix the issue, then maybe it is time for another browser. Is anyone actually paying attention to this issue?

I have read multiple responses to the ridiculous multi-threading "feature" in FF, tried all the suggested fixes, but none work. This one - The multi-process opt-in pref browser.tabs.remote.autostart.2 is no longer used in Firefox 58. In Firefox 58+ only browser.tabs.remote.autostart is used, so you need to set this pref to false to disable multi-process. also does not work - I have done this and gone back multiple times to check the setting, which hasn't changed from the False, but the multi-threading demon remains active. It is constantly crashing my system - not just the browser. And yes, I use the updated versions all the time. I really need to stop this feature once and for all, and if FF can't fix the issue, then maybe it is time for another browser. Is anyone actually paying attention to this issue?
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

jscher2000
  • Top 10 Contributor
8757 solutions 71653 answers

Hi nottyb123, you can reduce the number of content processes that Firefox will use, but it will still use at least one or two additional processes for the user interface and shared code of the browser itself.

This article shows where to modify the number of content processes: Firefox's performance settings.

Regarding crashes, if you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the support article "Firefox crashes - asking for support" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here.

If you get a Windows crash dialog instead, then Windows may have captured some data in the Applications event log. You might find that data using the Windows Event Viewer.

Hi nottyb123, you can reduce the number of ''content processes'' that Firefox will use, but it will still use at least one or two additional processes for the user interface and shared code of the browser itself. This article shows where to modify the number of content processes: [[Firefox's performance settings]]. Regarding crashes, if you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the support article "[[Firefox crashes - asking for support]]" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here. If you get a Windows crash dialog instead, then Windows may have captured some data in the Applications event log. You might find that data using the Windows Event Viewer.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.