X
Tap here to go to the mobile version of the site.

Support Forum

Stop auto "Download" of videos on web sites

Posted

I like to read news online from sites like: Foxnews, CNN, CBS, WSJ etc., and I have limited data available (Metered Service). On almost all of these sites I was able to stop auto play of the video by disabling auto play options, and adding disable HTML5 auto play extension when some sites managed to bypass the disabled auto play option. However, that didn't stop the sites from downloading the videos. I've tried everything that I've found online: content blocker, no script extensions, etc., but nothing seems to work. Does anyone know if there's an answer or a solution to this problem, or will I just have to limit my online site visits as some other forums suggest?

I like to read news online from sites like: Foxnews, CNN, CBS, WSJ etc., and I have limited data available (Metered Service). On almost all of these sites I was able to stop auto play of the video by disabling auto play options, and adding disable HTML5 auto play extension when some sites managed to bypass the disabled auto play option. However, that didn't stop the sites from downloading the videos. I've tried everything that I've found online: content blocker, no script extensions, etc., but nothing seems to work. Does anyone know if there's an answer or a solution to this problem, or will I just have to limit my online site visits as some other forums suggest?

Chosen solution

You could try an add-on such as the following if you haven't already:

https://addons.mozilla.org/firefox/addon/image-video-block/

Use its toolbar button to set your global default settings. When there's a site where you want site-specific settings, use the right-click context menu in the page. I don't see a way to make an exception just for one image or one page of a site.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

jscher2000
  • Top 10 Contributor
8695 solutions 71076 answers

Chosen Solution

You could try an add-on such as the following if you haven't already:

https://addons.mozilla.org/firefox/addon/image-video-block/

Use its toolbar button to set your global default settings. When there's a site where you want site-specific settings, use the right-click context menu in the page. I don't see a way to make an exception just for one image or one page of a site.

You could try an add-on such as the following if you haven't already: https://addons.mozilla.org/firefox/addon/image-video-block/ Use its toolbar button to set your global default settings. When there's a site where you want site-specific settings, use the right-click context menu in the page. I don't see a way to make an exception just for one image or one page of a site.
Was this helpful to you?
Quote

Question owner

Thanks for the advice, I've installed the addon and it seems to be stopping the downloads, but I'll have to watch my data usage to see if it's working, over the next few days. You're right, once it's set globally it works on all sites, which for me is okay. There are very few videos, Youtube or others, that I watch because of my data plan, so a global blockage of downloads is just fine. Thanks again for the quick response, I'll watch for a few days and let you know the results.

Thanks for the advice, I've installed the addon and it seems to be stopping the downloads, but I'll have to watch my data usage to see if it's working, over the next few days. You're right, once it's set globally it works on all sites, which for me is okay. There are very few videos, Youtube or others, that I watch because of my data plan, so a global blockage of downloads is just fine. Thanks again for the quick response, I'll watch for a few days and let you know the results.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4248 solutions 59413 answers

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution. Thank you for contacting Mozilla Support.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.