X
Tap here to go to the mobile version of the site.

Support Forum

Can't Open or Save any Attachments

Posted

Hello,

Since updating to Thunderbird 68.1.0 I a unable to open or save any attachments. When right clicking on the attachment file all options are greyed out and so is the save button in the bottom right hand corner.

I have tried the following but the issue still remains:

- Opening TB up in safe mode.
- Compacting all folders when it will save over 20MB
- Uninstalling and re-installing TB.
- I am using the default theme.

It's really frustrating as I use Google Apps mail and have to go to Gmail to download attachments.

A screen shot is attached of what I see.

Thanks in advance.

Jim Isles

Hello, Since updating to Thunderbird 68.1.0 I a unable to open or save any attachments. When right clicking on the attachment file all options are greyed out and so is the save button in the bottom right hand corner. I have tried the following but the issue still remains: - Opening TB up in safe mode. - Compacting all folders when it will save over 20MB - Uninstalling and re-installing TB. - I am using the default theme. It's really frustrating as I use Google Apps mail and have to go to Gmail to download attachments. A screen shot is attached of what I see. Thanks in advance. Jim Isles
Attached screenshots

Chosen solution

Hi Jim

Are you using a MAC or Linux or Windows OS ?

I notice the attachment is pdf and says 'size unknown'.


I've just been reading a bug on issue that sounds like yours and person said the following was a workaround. https://bugzilla.mozilla.org/show_bug.cgi?id=1576584 initial comment mentions "When a message with attachment is opened some attachments are marked as "size unknown" and there's no way they can be opened or saved." read: comment 25 and 27

Please try this: IF MAC: Thunderbird > Preferences > Advanced > General IF Linux: Edit > Preferences > Advanced > General IF Windows : Menu icon > Options > Options > Advanced > General

click on 'Config. editor' type in search: mime Look for this line: 'mail.server.default.mime_parts_on_demand' If value is True: double click on that line to toggle the value from True to false. close Preferences restart TB. To force a re-download of a message, open the Message Source (Ctrl+U).

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36

More Information

Toad-Hall
  • Top 10 Contributor
1767 solutions 11883 answers

Chosen Solution

Hi Jim

Are you using a MAC or Linux or Windows OS ?

I notice the attachment is pdf and says 'size unknown'.


I've just been reading a bug on issue that sounds like yours and person said the following was a workaround. https://bugzilla.mozilla.org/show_bug.cgi?id=1576584 initial comment mentions "When a message with attachment is opened some attachments are marked as "size unknown" and there's no way they can be opened or saved." read: comment 25 and 27

Please try this: IF MAC: Thunderbird > Preferences > Advanced > General IF Linux: Edit > Preferences > Advanced > General IF Windows : Menu icon > Options > Options > Advanced > General

click on 'Config. editor' type in search: mime Look for this line: 'mail.server.default.mime_parts_on_demand' If value is True: double click on that line to toggle the value from True to false. close Preferences restart TB. To force a re-download of a message, open the Message Source (Ctrl+U).

Hi Jim Are you using a MAC or Linux or Windows OS ? I notice the attachment is pdf and says 'size unknown'. I've just been reading a bug on issue that sounds like yours and person said the following was a workaround. https://bugzilla.mozilla.org/show_bug.cgi?id=1576584 initial comment mentions "When a message with attachment is opened some attachments are marked as "size unknown" and there's no way they can be opened or saved." read: comment 25 and 27 Please try this: IF MAC: Thunderbird > Preferences > Advanced > General IF Linux: Edit > Preferences > Advanced > General IF Windows : Menu icon > Options > Options > Advanced > General click on 'Config. editor' type in search: '''mime''' Look for this line: 'mail.server.default.mime_parts_on_demand' If value is True: double click on that line to toggle the value from True to '''false'''. close Preferences restart TB. To force a re-download of a message, open the Message Source (Ctrl+U).
Was this helpful to you?
Quote

Question owner

Hi,

Sorry I'm using a PC Windows 10.

It was happening with all attachments not just PDF.

Just carried out the fix as you said above and that seems to have fixed the issue I can now open and save the attachment I had issues with. Thank you that's a real help.

It all started happening after some emails with attachments were taking a long time to download and open hence the reason for updating then this happened. Fingers crossed that's then end of the issues.

Jim

Hi, Sorry I'm using a PC Windows 10. It was happening with all attachments not just PDF. Just carried out the fix as you said above and that seems to have fixed the issue I can now open and save the attachment I had issues with. Thank you that's a real help. It all started happening after some emails with attachments were taking a long time to download and open hence the reason for updating then this happened. Fingers crossed that's then end of the issues. Jim
Was this helpful to you?
Quote
Toad-Hall
  • Top 10 Contributor
1767 solutions 11883 answers

Thanks for feedback. I had heard about issues with Linux and Mac, but it is useful to know that the problem can also occur in Windows. Good to hear the workaround in config.editor seems to have fixed the issue. Could you select my previous comment as 'Chosen Solution' to help others looking for solution with same issue as you.

Thanks for feedback. I had heard about issues with Linux and Mac, but it is useful to know that the problem can also occur in Windows. Good to hear the workaround in config.editor seems to have fixed the issue. Could you select my previous comment as 'Chosen Solution' to help others looking for solution with same issue as you.
Was this helpful to you?
Quote

Question owner

No problem now done.

No problem now done.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.