Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search engine names are missing in Firefox 69's search bar

  • 8 replies
  • 1 has this problem
  • 611 views
  • Last reply by MartyJames

more options

The search engine names have disappeared once again!

I'd been running userChrome scripts to fix this "bug" (thanks to the help of people in this forum https://support.mozilla.org/en-US/questions/1192499#answer-1045326 ). But the names have disappeared again in version 69.

I do like Firefox, but sometimes I wonder what the interface designers are smoking. Who could possibly think that an unlabeled list of search engine icons is a useful way to search the internet!? For that matter, who on earth decided that users want to type their search terms FIRST and THEN decide what type of search they want to perform? Most of the time, people search the exact opposite way to this.

Modified by MartyJames

Chosen solution

In Firefox 68 it is no longer browser,xul, has changed to browser.xhtml

Maybe this is all you need to change:

@-moz-document url(chrome://browser/content/browser.xul) =>
@-moz-document url(chrome://browser/content/browser.xhtml) {
Read this answer in context 👍 2

All Replies (8)

more options

Hi MartyJames, In the What’s new in Firefox! for version 69.0 a change has been made:

"Firefox no longer loads userChrome.css or userContent.css by default improving start-up performance. Users who wish to customize Firefox by using these files can set the toolkit.legacyUserProfileCustomizations.stylesheets preference to true to restore this ability."

more options

Hmmm. That setting seems to be already set to true (status "modified", type "boolean", value "true") and yet my search engines have no text labels!?

I wonder if there's some way to test if userChrome is running or not?

more options

What code do you currently use?

more options

Edit:

Sorry, I tried posting but this forum's formatting syntax doesn't allow code to be posted. (For example, the hash/pound symbol is being changed into a numbered list.)

Modified by MartyJames

more options

OK, I've worked out a way to post the code. I have placed quotation marks around the asterisks and hash symbols…

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
#TabsToolbar {
    visibility: collapse;
}

/*
  HELLO! This script has optional settings that you can try out if you return to its page: https://userstyles.org/styles/122214/firefox-search-bar-show-engine-names-firefox-43
*/
@-moz-document url(chrome://browser/content/browser.xul) {
  /* Make the one-off buttons span the full width */
  #PopupSearchAutoComplete .searchbar-engine-one-off-item[tooltiptext] {
    width: 100% !important;
    height: 24px !important;
    background-image: none !important;
    padding-left: 6px !important;
    box-sizing: content-box !important;
    line-height: 1em !important;
  }
  /* Hide the empties */
  #PopupSearchAutoComplete .searchbar-engine-one-off-item:not([tooltiptext]) {
    display: none !important;
  }
  /* Fix up borders */
  #PopupSearchAutoComplete .searchbar-engine-one-off-item[tooltiptext], 
  #PopupSearchAutoComplete .addengine-item {
    border-bottom: 1px solid #ccc !important;
  }
  #PopupSearchAutoComplete .search-setting-button.search-panel-header, 
  #PopupSearchAutoComplete .addengine-item,
  #PopupSearchAutoComplete .search-panel-header.search-panel-current-input {
    border-top: none !important;
    max-height: 26px !important;
    min-height: 16px !important;
    padding-top: 1px !important;
  }
  /* Insert descriptive name for search engine plugin */
  #PopupSearchAutoComplete .searchbar-engine-one-off-item[tooltiptext]::after {
    content: attr(tooltiptext);
    margin: 5px 6px 0px !important;
    display: block !important;
  }
  /* Fix icon positioning */
  #PopupSearchAutoComplete .searchbar-engine-one-off-item[tooltiptext] > .button-box {
    display: inline-flex !important;
    width: 16px !important;
    max-width: 16px !important;
    border: none !important;
    padding: 0 0 !important;
  }
  #PopupSearchAutoComplete .searchbar-engine-one-off-item[tooltiptext] > .button-box > .button-icon {
    display: block !important;
    margin-top: 4px !important;
    margin-left: -1px !important;
  }
  /* Lock in space for 5 search suggestions with scroll bar */
  #PopupSearchAutoComplete .autocomplete-tree.plain.search-panel-tree .tree-bodybox,
  #PopupSearchAutoComplete .autocomplete-tree.plain.search-panel-tree .autocomplete-treebody {
    display: flex !important;
    flex: 1 1 auto !important;
  }
  #PopupSearchAutoComplete .autocomplete-tree.plain.search-panel-tree .autocomplete-treebody {
    max-height: calc(5 * 1.5em) !important;
    min-height: calc(5 * 1.5em) !important;
  }
  #PopupSearchAutoComplete .autocomplete-tree.plain.search-panel-tree .tree-scrollbar[collapsed="true"] {
    visibility: visible !important;
  }
  /* User style options */
    /* Two columns - standard spacing */
  #PopupSearchAutoComplete {
    width: calc(32em + 14px) !important;
    min-width: calc(32em + 14px) !important;
  }
  #PopupSearchAutoComplete .searchbar-engine-one-off-item[tooltiptext] {
    width: 16em !important;
    white-space: nowrap;
    overflow: hidden;
  }
    /* Hiding "Search for ..." */
  #PopupSearchAutoComplete .search-panel-header.search-panel-current-input {
    display: none !important;
  }
    /* Not hiding "Add ..." engine */
    /* Not hiding "Change Search Settings" */
    /* Search bar tooltip text only visible on mouseover */
    /* No color scheme */
    /* No color scheme for hover */
}

/*AGENT_SHEET*/

/* Firefox 57+ userChrome.css tweaks ****************************************************/
/* code mostly taken from 'Classic Theme Restorer' & 'Classic Toolbar Buttons' add-ons **/
/* by Aris (aris-addons@gmx.net)*********************************************************/
/* Github: https://github.com/aris-t2/customcssforfx ************************************/
/****************************************************************************************/



#PersonalToolbar {
  min-height: unset !important;
  max-height: unset !important;
/* text-align: center !important; */
}

#PersonalToolbar #PlacesToolbarItems {
  overflow-x: visible !important;
  overflow-y: visible !important;
  display: inline-block !important;
}

Modified by cor-el

more options

Chosen Solution

In Firefox 68 it is no longer browser,xul, has changed to browser.xhtml

Maybe this is all you need to change:

@-moz-document url(chrome://browser/content/browser.xul) =>
@-moz-document url(chrome://browser/content/browser.xhtml) {
more options

Thanks so much cor-el! :-) Your solution worked!

It was simply a case of changing a "u" to an "htm"!