X
Tap here to go to the mobile version of the site.

Support Forum

History is not being saved Only shows up to May 2019.

Posted

When I click on History Show All History I only get a list showing May, April and Older than 6 months. How do I get all my history to show again?

When I click on History Show All History I only get a list showing May, April and Older than 6 months. How do I get all my history to show again?

Chosen solution

Try going to Help -> Troubleshooting Information. Scroll down the page to the "Places Database" section and click the "Verify Integrity" button.

It may take a few seconds.

Copy the output of that run (if it doesn't help, we'd like you to paste it here), and restart Firefox, then visit a few pages and see if history starts appearing.

If it doesn't help, please paste the output of the verify integrity here so we can try and advise you further.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

Standard8 37 solutions 211 answers

Chosen Solution

Try going to Help -> Troubleshooting Information. Scroll down the page to the "Places Database" section and click the "Verify Integrity" button.

It may take a few seconds.

Copy the output of that run (if it doesn't help, we'd like you to paste it here), and restart Firefox, then visit a few pages and see if history starts appearing.

If it doesn't help, please paste the output of the verify integrity here so we can try and advise you further.

Try going to Help -> Troubleshooting Information. Scroll down the page to the "Places Database" section and click the "Verify Integrity" button. It may take a few seconds. Copy the output of that run (if it doesn't help, we'd like you to paste it here), and restart Firefox, then visit a few pages and see if history starts appearing. If it doesn't help, please paste the output of the verify integrity here so we can try and advise you further.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17764 solutions 160655 answers

Also make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"
Also make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history" *remove checkmark: [ ] "Always use Private Browsing mode"
Was this helpful to you? 1
Quote

Question owner

I was able to get it to start showing the history again by just turning show history off and on a couple times but that does not help with all that was lost even the last few days. I guess there is no way to retrieve that history? But in any case I guess the problem is solved. Thx

I was able to get it to start showing the history again by just turning show history off and on a couple times but that does not help with all that was lost even the last few days. I guess there is no way to retrieve that history? But in any case I guess the problem is solved. Thx
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.