X
Tap here to go to the mobile version of the site.

Support Forum

Login and password available only in safe mode

Posted

FF Version 68.0.2 and Mac OS X 10.14.6. No login and password available using FF, opening login window under settings no data saved (showed). Opening FF in safe mode all login and password are visible and stored. Any idea how to fix?

FF Version 68.0.2 and Mac OS X 10.14.6. No login and password available using FF, opening login window under settings no data saved (showed). Opening FF in safe mode all login and password are visible and stored. Any idea how to fix?

Chosen solution

I did some more searching and came across a few threads in which the OPs had the same problem - the only thing that fixed the problem for them was to Refresh Firefox .....

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

n/a

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

McCoy
  • Top 10 Contributor
534 solutions 5036 answers

Hello matteo.pontremoli,

Stab in the dark, but could it be that you have an external password manager installed ? If so : would you please disable it and see if that will make a difference ? I'm asking because you mention that the problem does not occur in Safe Mode .....

Hello matteo.pontremoli, Stab in the dark, but could it be that you have an external password manager installed ? If so : would you please disable it and see if that will make a difference ? I'm asking because you mention that the problem does not occur in Safe Mode .....
Was this helpful to you?
Quote

Question owner

Thnks McCoy, no password manager installed: just as update: I try to remove key3.db, key4.db and logins.json from my profile folder - open FF in normal mode - logon to a site and safe login and psw and seems ok. No login/password has been saved, safe or normal mode! :-(

Thnks McCoy, no password manager installed: just as update: I try to remove key3.db, key4.db and logins.json from my profile folder - open FF in normal mode - logon to a site and safe login and psw and seems ok. No login/password has been saved, safe or normal mode! :-(
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
534 solutions 5036 answers

Let me see if I'm not misconstruing what you're saying :

It is just that in Preferences => Privacy & Security, under 'Loggins and Passwords", "Saved Logins" is empty, but the box "Ask to save logins and passwords for websites" is checked  ?

If that box is not checked, would you please make sure that you're not in permanent Private Browsing mode ?

Preferences => Privacy & Security => History Choose : "Use custom settings for history" Make sure that "Always use private browsing mode" is unchecked.

Let me see if I'm not misconstruing what you're saying : It is just that in Preferences => Privacy & Security, under 'Loggins and Passwords", "Saved Logins" is empty, but the box "Ask to save logins and passwords for websites" is checked ? If that box is not checked, would you please make sure that you're not in permanent Private Browsing mode ? Preferences => Privacy & Security => History Choose : "Use custom settings for history" Make sure that "Always use private browsing mode" is unchecked.
Was this helpful to you?
Quote

Question owner

McCoy said

Let me see if I'm not misconstruing what you're saying : It is just that in Preferences => Privacy & Security, under 'Loggins and Passwords", "Saved Logins" is empty, but the box "Ask to save logins and passwords for websites" is checked  ?
yes, empty and options is checked running FF in normal mode. if I run FF in safe mode logins and password are filled

Preferences => Privacy & Security => History Choose : "Use custom settings for history" Make sure that "Always use private browsing mode" is unchecked.

Confirmed, is unchecked.
''McCoy [[#answer-1247544|said]]'' <blockquote> Let me see if I'm not misconstruing what you're saying : It is just that in Preferences => Privacy & Security, under 'Loggins and Passwords", "Saved Logins" is empty, but the box "Ask to save logins and passwords for websites" is checked ? <blockquote> yes, empty and options is checked running FF in normal mode. if I run FF in safe mode logins and password are filled </blockquote> Preferences => Privacy & Security => History Choose : "Use custom settings for history" Make sure that "Always use private browsing mode" is unchecked. <blockquote> Confirmed, is unchecked. </blockquote>
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
534 solutions 5036 answers

If in Safe Mode "Saved Loggins" is filled, then it could be one of your add-ons - hence I asked if you had an external password manager installed ..... But it could be another add-on (if you have any ?) - if so : would you please disable them one by one and the re-enable them one by one untill you find the culprit >

If in Safe Mode "Saved Loggins" is filled, then it could be one of your add-ons - hence I asked if you had an external password manager installed ..... But it could be another add-on (if you have any ?) - if so : would you please disable them one by one and the re-enable them one by one untill you find the culprit >
Was this helpful to you?
Quote

Question owner

McCoy said

If in Safe Mode "Saved Loggins" is filled, then it could be one of your add-ons - hence I asked if you had an external password manager installed ..... But it could be another add-on (if you have any ?) - if so : would you please disable them one by one and the re-enable them one by one untill you find the culprit >

All add-ons has been disabled one by one, and at the end I removed them - same situations in normal mode. No plugin, extensions or other components.

''McCoy [[#answer-1247547|said]]'' <blockquote> If in Safe Mode "Saved Loggins" is filled, then it could be one of your add-ons - hence I asked if you had an external password manager installed ..... But it could be another add-on (if you have any ?) - if so : would you please disable them one by one and the re-enable them one by one untill you find the culprit > </blockquote> All add-ons has been disabled one by one, and at the end I removed them - same situations in normal mode. No plugin, extensions or other components.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
534 solutions 5036 answers

matteo.pontremoli said

just as update: I try to remove key3.db, key4.db and logins.json from my profile folder

This time, would you try to rename or remove the secmod.db file ?

''matteo.pontremoli [[#answer-1247540|said]]'' <blockquote> just as update: I try to remove key3.db, key4.db and logins.json from my profile folder </blockquote> This time, would you try to rename or remove the '''secmod.db''' file ?
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
534 solutions 5036 answers

If none of the above solve the problem, and as the saved logins do show in Safe Mode - would you disable hardware acceleration please :

https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration

If none of the above solve the problem, and as the saved logins do show in Safe Mode - would you disable hardware acceleration please : https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration
Was this helpful to you?
Quote

Question owner

Bad news, all the suggestion didn't fix the issue. my last attempt: I copy my profile folder from mac to usb key and copy it using the same version of FF to on another pc (windows) and... the problem is not present! all the login and password are available and showed.

This means that the problem should on mac version of FF or on mac side. Any help will be appreciate.

Bad news, all the suggestion didn't fix the issue. my last attempt: I copy my profile folder from mac to usb key and copy it using the same version of FF to on another pc (windows) and... the problem is not present! all the login and password are available and showed. This means that the problem should on mac version of FF or on mac side. Any help will be appreciate.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
534 solutions 5036 answers

The only thing I can think of right now is to ask you if maybe you're using AVG or Avast security software ...... and if so : would you please disable it and see if that will make a difference ?

(I thought I had posted this question before, but I must have forgotten to press "Post Reply" ..... )

The only thing I can think of right now is to ask you if maybe you're using AVG or Avast security software ...... and if so : would you please disable it and see if that will make a difference ? (I thought I had posted this question before, but I must have forgotten to press "Post Reply" ..... )
Was this helpful to you?
Quote

Question owner

Nope.. Waiting for idea or alternative, the only option is run FF in safe mode :-( Thanks for your help!

Nope.. Waiting for idea or alternative, the only option is run FF in safe mode :-( Thanks for your help!
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
534 solutions 5036 answers

matteo.pontremoli said

Nope.. Waiting for idea or alternative, the only option is run FF in safe mode :-( Thanks for your help!

One last thing I'd like to ask :

Do you by any chance have a userChrome.css file in your profile folder ?

''matteo.pontremoli [[#answer-1247784|said]]'' <blockquote> Nope.. Waiting for idea or alternative, the only option is run FF in safe mode :-( Thanks for your help! </blockquote> One last thing I'd like to ask : Do you by any chance have a userChrome.css file in your profile folder ?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17483 solutions 157999 answers

You can set signon.debug to true on the about:config page to see if there are some error messages in the Browser Console.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can set <b>signon.debug</b> to true on the <b>about:config</b> page to see if there are some error messages in the Browser Console. *https://developer.mozilla.org/en-US/Tools/Browser_Console You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox
Was this helpful to you?
Quote

Question owner

cor-el said

You can set signon.debug to true on the about:config page to see if there are some error messages in the Browser Console. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

cor-el, only messages in console that shuold be related to issue:

OpenGL compositor Initialized Succesfully. Version: 2.1 INTEL-12.10.12 Vendor: Intel Inc. Renderer: Intel(R) Iris(TM) Plus Graphics 655 FBO Texture Target: TEXTURE_2D NS_ERROR_FAILURE: Couldn't decrypt string 289 crypto-SDR.js:181

Thxs for your support

''cor-el [[#answer-1247787|said]]'' <blockquote> You can set <b>signon.debug</b> to true on the <b>about:config</b> page to see if there are some error messages in the Browser Console. *https://developer.mozilla.org/en-US/Tools/Browser_Console You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox </blockquote> cor-el, only messages in console that shuold be related to issue: OpenGL compositor Initialized Succesfully. Version: 2.1 INTEL-12.10.12 Vendor: Intel Inc. Renderer: Intel(R) Iris(TM) Plus Graphics 655 FBO Texture Target: TEXTURE_2D NS_ERROR_FAILURE: Couldn't decrypt string 289 crypto-SDR.js:181 Thxs for your support
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
534 solutions 5036 answers

Chosen Solution

I did some more searching and came across a few threads in which the OPs had the same problem - the only thing that fixed the problem for them was to Refresh Firefox .....

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

I did some more searching and came across a few threads in which the OPs had the same problem - the only thing that fixed the problem for them was to Refresh Firefox ..... https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings
Was this helpful to you? 0
Quote

Question owner

McCoy said

I did some more searching and came across a few threads in which the OPs had the same problem - the only thing that fixed the problem for them was to Refresh Firefox ..... https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

At the end the only way was refresh FF. Problem fixed, thnxs to McCoy and Cor-el for support!

''McCoy [[#answer-1248320|said]]'' <blockquote> I did some more searching and came across a few threads in which the OPs had the same problem - the only thing that fixed the problem for them was to Refresh Firefox ..... https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings </blockquote> At the end the only way was refresh FF. Problem fixed, thnxs to McCoy and Cor-el for support!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.