X
Tap here to go to the mobile version of the site.

Support Forum

Spotify web player won't work in Firefox

Posted

When I try to access the web player, it directs me to their support site and tells me to enable "Play DRM-controlled content" in Firefox settings. I have enabled that setting, the box is checked, but the web player still does not work and tells me I need to enable DRM contents. Is there anything else I can do to make Spotify web player work?

When I try to access the web player, it directs me to their support site and tells me to enable "Play DRM-controlled content" in Firefox settings. I have enabled that setting, the box is checked, but the web player still does not work and tells me I need to enable DRM contents. Is there anything else I can do to make Spotify web player work?
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

Ballison
  • Top 25 Contributor
  • Administrator
13 solutions 74 answers

Hi Benno,

This could be an issue with one of your plugins that enables media playback not working correctly, so let's take a look at that first.

1.) Navigate to about:addons

2.) Select "Plugins" on the left side.

3.) Look for a plugin titled "Widevine Content Decryption Module provided by Google Inc."

4.) Click on the 3 dots on the right side of the plugin and ensure it is set to "Always Activate".

Now head to about:preferences and double check again that your have the DRM box checked. Fire up the Spotify web player and let me know if it works!

Hi Benno, This could be an issue with one of your plugins that enables media playback not working correctly, so let's take a look at that first. 1.) Navigate to about:addons 2.) Select "Plugins" on the left side. 3.) Look for a plugin titled "Widevine Content Decryption Module provided by Google Inc." 4.) Click on the 3 dots on the right side of the plugin and ensure it is set to "Always Activate". Now head to about:preferences and double check again that your have the DRM box checked. Fire up the Spotify web player and let me know if it works!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.