X
Tap here to go to the mobile version of the site.

Support Forum

Spotify requires I enable DRM & gave instructions how but option to enable not there!

Posted

I tried to open the spotify web player. It said "Playback of protected content is not enabled." It gave me instructions, saying "Enter the following into your browser address bar: about:preferences#content. Under DRM content, make sure Play DRM content is enabled." But the option is not there. on any version of firefox I've looked at.

I tried to open the spotify web player. It said "Playback of protected content is not enabled." It gave me instructions, saying "Enter the following into your browser address bar: about:preferences#content. Under DRM content, make sure Play DRM content is enabled." But the option is not there. on any version of firefox I've looked at.

Chosen solution

Is this feature enabled for Windows XP?

https://support.mozilla.org/en-US/kb/enable-drm#firefox:winxp:fx52

Supported platforms Google Widevine

  • Windows Vista and higher
  • Mac OS X 10.9 and higher
  • x86 and x64 Linux
Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Shockwave Flash 25.0 r0
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

Pkshadow
  • Top 10 Contributor
245 solutions 2666 answers

When Options are opened using above command given Go to the Content menu left side and click. DRM content is listed as the very 1st thing at page top. Af it is not there please come back and let us know and if is there please come back and mark this as solved.

I would also suggest you update your browser from ver 52 to ver 54 by using from Menu Bar: Help, then About or what ever way you use.

When Options are opened using above command given Go to the Content menu left side and click. DRM content is listed as the very 1st thing at page top. Af it is not there please come back and let us know and if is there please come back and mark this as solved. I would also suggest you update your browser from ver 52 to ver 54 by using from Menu Bar: Help, then About or what ever way you use.
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
6603 solutions 54016 answers

Hi Pkshadow:

Pkshadow said

I would also suggest you update your browser from ver 52 to ver 54 by using from Menu Bar: Help, then About or what ever way you use.

If the user's Firefox reported accurately that the operating system is Windows XP, the newest available release in 52.2.0esr (a level of detail we cannot detect from the user agent information).

Hi Pkshadow: ''Pkshadow [[#answer-979102|said]]'' <blockquote> I would also suggest you update your browser from ver 52 to ver 54 by using from Menu Bar: Help, then About or what ever way you use. </blockquote> If the user's Firefox reported accurately that the operating system is Windows XP, the newest available release in 52.2.0esr (a level of detail we cannot detect from the user agent information).
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
6603 solutions 54016 answers

You can re-enable DRM "the hard way" as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste eme. and pause while the list is filtered

(3) If the browser.eme.ui.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true -- when this is false, the checkbox is hidden from the Options page

(4) If the media.eme.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true -- this corresponds to the checkbox (true = checked, false = unchecked)

Does that make any difference?

Assuming you didn't modify those yourself, possibly one of your add-ons did it??

Speaking of add-ons, you probably need the Widevine plugin enabled. You can check that on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, look for "Widevine Content Decryption Module provided by Google" and make sure it has the "Always Activate" permission.

Support article: Watch DRM content on Firefox

You can re-enable DRM "the hard way" as follows: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''eme.''' and pause while the list is filtered (3) If the '''browser.eme.ui.enabled''' preference is bolded and "user set" to false, double-click it to restore the default value of true -- when this is false, the checkbox is hidden from the Options page (4) If the '''media.eme.enabled''' preference is bolded and "user set" to false, double-click it to restore the default value of true -- this corresponds to the checkbox (true = checked, false = unchecked) Does that make any difference? Assuming you didn't modify those yourself, possibly one of your add-ons did it?? Speaking of add-ons, you probably need the Widevine plugin enabled. You can check that on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, look for "Widevine Content Decryption Module provided by Google" and make sure it has the "Always Activate" permission. Support article: [[Watch DRM content on Firefox]]
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15584 solutions 141084 answers

Chosen Solution

Is this feature enabled for Windows XP?

https://support.mozilla.org/en-US/kb/enable-drm#firefox:winxp:fx52

Supported platforms Google Widevine

  • Windows Vista and higher
  • Mac OS X 10.9 and higher
  • x86 and x64 Linux
Is this feature enabled for Windows XP? https://support.mozilla.org/en-US/kb/enable-drm#firefox:winxp:fx52 Supported platforms Google Widevine * Windows Vista and higher * Mac OS X 10.9 and higher * x86 and x64 Linux
Was this helpful to you? 0
Quote
pvalanne 0 solutions 1 answers

Had same problem with Spotify web player not starting, none of above solutions worked.

Switching User Agent to IE (Microsoft Internet Explorer) did work!


MORE DETAILS

Using Firefox 52.3.0esr on Windows XP (32-bit): - Under Content Options there are no DRM options - .eme. options were already enabled (True)

Navigation to play.spotify.com automatically redirected to open.spotify.com, resulting in error messages:

  • "Playback of protected content is not enabled." (same as OP)
  • "Enable player in your browser"
  • "Visit the Spotify support site to see how."

Solution that did work was installing a User-Agent Switcher and posing as IE - in my case, specifically:

  • Mozilla/5.0 (Windows NT 10.0; Trident/7.0; rv:11.0) like Gecko

HTH!

Had same problem with Spotify web player not starting, none of above solutions worked. Switching User Agent to '''IE''' (Microsoft Internet Explorer) ''did'' work! ---------------------- MORE DETAILS Using Firefox 52.3.0esr on Windows XP (32-bit): - Under Content Options there are no DRM options - '''.eme.''' options were already enabled (True) Navigation to play.spotify.com automatically redirected to open.spotify.com, resulting in error messages: * "Playback of protected content is not enabled." (same as OP) * "Enable player in your browser" * "Visit the Spotify support site to see how." Solution that ''did'' work was installing a '''User-Agent Switcher''' and posing as IE - in my case, specifically: * Mozilla/5.0 (Windows NT 10.0; Trident/7.0; rv:11.0) like Gecko HTH!
Was this helpful to you? 3
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.